View Issue Details

IDProjectCategoryView StatusLast Update
0003638OpenFOAMBugpublic2021-03-08 09:34
ReportergskillasAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSOpenSUSE LeapOS Version15.2
Product Versiondev 
Fixed in Versiondev 
Summary0003638: snappyHexMesh fails to compile
DescriptionsnappyHexMesh.C: In function ‘int main(int, char**)’:
snappyHexMesh.C:735:76: error: no matching function for call to ‘Foam::IOdictionary::IOdictionary(Foam::dictionary)’
     const IOdictionary meshDict(systemDict("snappyHexMeshDict", args, mesh));
                                                                            ^
In file included from /home/cfd/OpenFOAM/OpenFOAM-dev/src/OpenFOAM/lnInclude/Time.H:43:0,
                 from snappyHexMesh.C:33:
/home/cfd/OpenFOAM/OpenFOAM-dev/src/OpenFOAM/lnInclude/IOdictionary.H:93:9: note: candidate: Foam::IOdictionary::IOdictionary(Foam::IOdictionary&&)
         IOdictionary(IOdictionary&&);
         ^~~~~~~~~~~~
/home/cfd/OpenFOAM/OpenFOAM-dev/src/OpenFOAM/lnInclude/IOdictionary.H:93:9: note: no known conversion for argument 1 from ‘Foam::dictionary’ to ‘Foam::IOdictionary&&’
/home/cfd/OpenFOAM/OpenFOAM-dev/src/OpenFOAM/lnInclude/IOdictionary.H:90:9: note: candidate: Foam::IOdictionary::IOdictionary(const Foam::IOdictionary&)
         IOdictionary(const IOdictionary&);
         ^~~~~~~~~~~~
/home/cfd/OpenFOAM/OpenFOAM-dev/src/OpenFOAM/lnInclude/IOdictionary.H:90:9: note: no known conversion for argument 1 from ‘Foam::dictionary’ to ‘const Foam::IOdictionary&’
/home/cfd/OpenFOAM/OpenFOAM-dev/src/OpenFOAM/lnInclude/IOdictionary.H:87:9: note: candidate: Foam::IOdictionary::IOdictionary(const Foam::IOobject&, Foam::Istream&)
         IOdictionary(const IOobject&, Istream&);
         ^~~~~~~~~~~~
/home/cfd/OpenFOAM/OpenFOAM-dev/src/OpenFOAM/lnInclude/IOdictionary.H:87:9: note: candidate expects 2 arguments, 1 provided
/home/cfd/OpenFOAM/OpenFOAM-dev/src/OpenFOAM/lnInclude/IOdictionary.H:84:9: note: candidate: Foam::IOdictionary::IOdictionary(const Foam::IOobject&, const Foam::dictionary&)
         IOdictionary(const IOobject&, const dictionary&);
         ^~~~~~~~~~~~
/home/cfd/OpenFOAM/OpenFOAM-dev/src/OpenFOAM/lnInclude/IOdictionary.H:84:9: note: candidate expects 2 arguments, 1 provided
/home/cfd/OpenFOAM/OpenFOAM-dev/src/OpenFOAM/lnInclude/IOdictionary.H:81:9: note: candidate: Foam::IOdictionary::IOdictionary(const Foam::IOobject&)
         IOdictionary(const IOobject&);
         ^~~~~~~~~~~~
/home/cfd/OpenFOAM/OpenFOAM-dev/src/OpenFOAM/lnInclude/IOdictionary.H:81:9: note: no known conversion for argument 1 from ‘Foam::dictionary’ to ‘const Foam::IOobject&’
/home/cfd/OpenFOAM/OpenFOAM-dev/src/OpenFOAM/lnInclude/IOdictionary.H:65:9: note: candidate: Foam::IOdictionary::IOdictionary(const Foam::IOobject&, const Foam::word&)
         IOdictionary(const IOobject& io, const word& wantedType);
         ^~~~~~~~~~~~
/home/cfd/OpenFOAM/OpenFOAM-dev/src/OpenFOAM/lnInclude/IOdictionary.H:65:9: note: candidate expects 2 arguments, 1 provided
make[2]: *** [/home/cfd/OpenFOAM/OpenFOAM-dev/wmake/rules/General/transform:26: /home/cfd/OpenFOAM/OpenFOAM-dev/platforms/linux64GccDPInt32Opt/applications/utilities/mesh/generation/snappyHexMesh/snappyHexMesh.o] Error 1
make[1]: *** [/home/cfd/OpenFOAM/OpenFOAM-dev/wmake/makefiles/apps:39: generation] Error 2
make: *** [/home/cfd/OpenFOAM/OpenFOAM-dev/wmake/makefiles/apps:39: mesh] Error 2
cfd@chalki ~/OpenFOAM/OpenFOAM-dev > cat /etc/os-release
NAME="openSUSE Leap"
VERSION="15.2"
ID="opensuse-leap"
ID_LIKE="suse opensuse"
VERSION_ID="15.2"
PRETTY_NAME="openSUSE Leap 15.2"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:leap:15.2"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org/"
cfd@chalki ~/OpenFOAM/OpenFOAM-dev > git pull
Already up to date.
Steps To ReproduceBoth fail

> git pull
> ./Allwmake -update

> wcleanPlatform
> git pull
> ./Allwmake
TagsNo tags attached.

Activities

henry

2021-03-07 12:09

manager   ~0011925

I am unable to reproduce this problem, everything is compiling fine with gcc and clang. What gcc version are you using and which have you tried?

henry

2021-03-07 12:12

manager   ~0011926

I tested and older gcc version and reproduced the problem, try with

commit a28fd5552f63757bb90cc8c03e779a96aaaa53a0 (HEAD -> master, origin/master, origin/HEAD)
Author: Henry Weller <http://cfd.direct>
Date: Sun Mar 7 12:11:39 2021 +0000

    systemDict: Changed return to IOdictionary

Issue History

Date Modified Username Field Change
2021-03-07 11:26 gskillas New Issue
2021-03-07 12:09 henry Note Added: 0011925
2021-03-07 12:12 henry Note Added: 0011926
2021-03-08 09:34 henry Assigned To => henry
2021-03-08 09:34 henry Status new => resolved
2021-03-08 09:34 henry Resolution open => fixed
2021-03-08 09:34 henry Fixed in Version => dev