View Issue Details

IDProjectCategoryView StatusLast Update
0003616OpenFOAMBugpublic2021-01-29 09:03
ReportervirajbelekarAssigned Towill 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformGNU/LinuxOSUbuntuOS Version18.04.5 LTS
Product Version8 
Fixed in Version 
Summary0003616: Heat and Mass Transfer issue when stationaryPhaseModel is used in multiphaseEulerFoam,basicMultiphaseSystem solves mass transfer
DescriptionThis is related to the issue reported here: https://bugs.openfoam.org/view.php?id=3612

This is a major issue in computing multiphase heat and mass transfer when there is no motion.

Issue 1: To give you a background, I am trying to simulate heat transfer between solid, liquid, and gas phases and mass transfer between the liquid and the gas phases for a stationary case. Initially, I set the solid phase to pureStationaryPhaseModel as all the phases have zero velocity (all the case files can be found in the attached HT_MT case directory). Now, if we change the solid phase to purePhaseModel, the phases heat up very quickly in less than 1 s. I know that the solver will solve for additional mass and momentum equations for the solid phase but the physics of heat and mass transfer should not change as the velocities for the three phases are still zero.

Issue 2: Now, if I only want to simulate heat transfer (and NOT mass transfer) between the three phases, I switch to basicMultiphaseSystem (all the case files can be found in the attached onlyHT case directory) and remove all the entries of diffusiveMassTransfer from the phaseProperties file. However, mass transfer still happens as the volume-averaged volume fraction of the liquid decreases with time. From my understanding, mass transfer should not happen when basicMultiphaseSystem is used. 
Steps To ReproduceTo reproduce issue 1, following are the commands:
cd HT_MT
blockMesh
multiphaseEulerFoam

To compare the cases when solid is defined as non-stationary but with zero velocity, go to HT_MT/constant/phaseProperties, change pureStationaryPhaseModel to purePhaseModel for the solid phase, and use the commands listed above.

To reproduce issue 2, following are the commands:
cd onlyHT
blockMesh
multiphaseEulerFoam
TagsNo tags attached.

Activities

virajbelekar

2021-01-21 19:56

reporter  

caseSetup.zip (50,292 bytes)

will

2021-01-22 10:28

manager   ~0011823

Last edited: 2021-01-22 10:28

View 2 revisions

OK, this case runs. We are making progress.
 
The problem now is that it takes 12hs+ to reach the first time dump. Imagine trying to use this case to figure out what is wrong with the code. Change something in the code. Wait a day for it to run. Change something else. Wait another day. See the problem? Figuring out the issue, if there is one, could take weeks.

Please create a smaller case that can be run, ideally in a matter of seconds, that demonstrates the problem. The case is basically just a big cylinder. Perhaps a 1D column with the same top and bottom boundaries would demonstrate the same behaviour?

will

2021-01-22 10:31

manager   ~0011824

Also, issue #2 is not a demonstration of mass transfer. multiphaseEulerFoam is only conservative at convergence, so the change in mass probably just means that your simulation isn't sufficiently converged.

virajbelekar

2021-01-23 21:56

reporter   ~0011825

Hello,

Please find the attached file. I made a 2D case.
Thank you for all your time and help.

Best,
Viraj

caseSetup-2.zip (58,000 bytes)

will

2021-01-26 11:16

manager   ~0011827

When I switch the solid to `purePhaseModel` as instructed then the case crashes before any output is generated. Did you not even run your own "steps to reproduce"?. Also, the unmodified case still takes 20 minutes. Why is it 2D and not 1D as I suggested?

Upload something which works and is quick to run (< 5minutes), or I will close the report.

virajbelekar

2021-01-27 20:25

reporter   ~0011828

Hello Will,

I thought that a 2D case will represent the physics of the problem more accurately.
Attached is a 1D case. I have checked the simulations and they work correctly.

Best Regards
Viraj

HT_MT.zip (28,643 bytes)

will

2021-01-29 09:03

manager   ~0011829

It still doesn't run in 8 or dev. Your coded boundary conditions are looking up non-existent fields again. Closing.

Issue History

Date Modified Username Field Change
2021-01-21 19:56 virajbelekar New Issue
2021-01-21 19:56 virajbelekar File Added: caseSetup.zip
2021-01-22 10:28 will Note Added: 0011823
2021-01-22 10:28 will Note Edited: 0011823 View Revisions
2021-01-22 10:31 will Note Added: 0011824
2021-01-23 21:56 virajbelekar File Added: caseSetup-2.zip
2021-01-23 21:56 virajbelekar Note Added: 0011825
2021-01-26 11:16 will Note Added: 0011827
2021-01-27 20:25 virajbelekar File Added: HT_MT.zip
2021-01-27 20:25 virajbelekar Note Added: 0011828
2021-01-29 09:03 will Assigned To => will
2021-01-29 09:03 will Status new => closed
2021-01-29 09:03 will Resolution open => unable to reproduce
2021-01-29 09:03 will Note Added: 0011829