View Issue Details

IDProjectCategoryView StatusLast Update
0003596OpenFOAMBugpublic2020-11-22 14:27
Reportershock77Assigned Tohenry 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformGNU/LinuxOSUbuntuOS Version12.04
Product Version7 
Fixed in Version 
Summary0003596: Boundary Conditions are changed when decomposing
DescriptionHi,


I have noticed that decomposePar changes the boundary conditions, which is very annoying if you want to use many cores.


For e.g. it changed:


    outlet
    {
        type waveTransmissive;
        field p;
        psi thermo:psi;
        fieldInf 101325;
        gamma 1.4;
        lInf 1;
        value uniform 101325;
    }

To:



    outlet
    {
        type waveTransmissive;
        gamma 1;
        fieldInf 101325;
        lInf 1;
        value nonuniform 0();
    }

If I use gamma 7/5, I get gamma 7 in the end.

I have tried that with openfoam4, openfoam5 and openfoam7 and the issue remains the same. I have actually noticed it by accident. I have also
discovered, that renumberMesh leads to the same issue.

I have attached a modified tutorial case (forwardStep) to clearify what I mean.
TagsNo tags attached.

Activities

shock77

2020-11-21 13:25

reporter  

forwardStep.zip (1,686,101 bytes)

henry

2020-11-21 16:55

manager   ~0011696

Last edited: 2020-11-21 19:39

View 2 revisions

In the case you provide it is not

    gamma 1.4

but

    gamma 7/5;
    
and 7/5 is not a scalar value and is read as the integer 7. I corrected it to 1.4 and decomposed in OpenFOAM-dev and get

    outlet
    {
        type waveTransmissive;
        gamma 1.4;
        fieldInf 101325;
        lInf 1;
        value nonuniform List<scalar> 0();
    }

henry

2020-11-21 17:02

manager   ~0011697

in processor0/0/p

OpenFOAM-8:

    outlet
    {
        type waveTransmissive;
        gamma 1.4;
        fieldInf 101325;
        lInf 1;
        value nonuniform List<scalar> 0();
    }

OpenFOAM-7:

    outlet
    {
        type waveTransmissive;
        gamma 1.4;
        fieldInf 101325;
        lInf 1;
        value nonuniform 0();
    }

OpenFOAM-6:

    outlet
    {
        type waveTransmissive;
        gamma 1.4;
        fieldInf 101325;
        lInf 1;
        value nonuniform 0();
    }

henry

2020-11-21 17:03

manager   ~0011698

Last edited: 2020-11-21 19:39

View 2 revisions

After OpenFOAM-6/7/8/dev renumberMesh:

    outlet
    {
        type waveTransmissive;
        gamma 1.4;
        fieldInf 101325;
        lInf 1;
        value uniform 101325;
    }

shock77

2020-11-22 12:36

reporter   ~0011731

Thank you for the effort!

As I mentioned, gamma 1.4 has lead to gamma 1 and gamma 7/5 to gamma 5/7. I provided only the later case.
I tried that several times. The reason why I tried 7/5 was, that gamma 1.4 has lead to gamma 1.

I just tried your suggestion at home and it works on openfoam4.1 and openfoam7 if you set gamma to 1.4.


I still dont know whats the issue at work, but I guess a reinstallation should fix it, since its not a problem with openfoam.

Issue History

Date Modified Username Field Change
2020-11-21 13:25 shock77 New Issue
2020-11-21 13:25 shock77 File Added: forwardStep.zip
2020-11-21 16:55 henry Note Added: 0011696
2020-11-21 17:02 henry Note Added: 0011697
2020-11-21 17:03 henry Note Added: 0011698
2020-11-21 19:39 henry Note Edited: 0011696 View Revisions
2020-11-21 19:39 henry Note Edited: 0011698 View Revisions
2020-11-22 12:36 shock77 Note Added: 0011731
2020-11-22 14:27 henry Assigned To => henry
2020-11-22 14:27 henry Status new => closed
2020-11-22 14:27 henry Resolution open => unable to reproduce