View Issue Details

IDProjectCategoryView StatusLast Update
0003579OpenFOAMBugpublic2020-10-20 11:42
ReportermohammadAssigned Tohenry 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformOSUbuntuOS Version 16.04.7
Product Version8 
Fixed in Version 
Summary0003579: setsToZones does not find sets directory for multiregion meshes
Description--> FOAM FATAL ERROR:
Cannot find directory "hh/polyMesh/sets" in times "0" down to constant

    From function virtual Foam::IOobject Foam::fileOperation::findInstance(const Foam::IOobject&, Foam::scalar, const Foam::word&) const
    in file global/fileOperations/fileOperation/fileOperation.C at line 818.

FOAM exiting

......................................................................................................................................................................................
This error is appeared when the cellSet option is used as selection mode in heat source as follows:

heatSource
{
   type semiImplicitSource;
    active true;
    semiImplicitSourceCoeffs
    {
        selectionMode cellSet;
        cellSet hh;
        volumeMode specific;
        injectionRateSuSp
        {
              T (400 0);
        }

    }
}

In case cellZone option is used as selection mode, the T option is ignored and it is not used as follows:
--> FOAM Warning :
Source heatSource defined for field T but never used.
Additional InformationThis error also is observed in OpenFOAM-v1712.
TagsNo tags attached.

Activities

henry

2020-10-20 11:42

manager   ~0011635

There is not enough information to reproduce the problem, it is likely that you are not using setsToZones correctly.

Issue History

Date Modified Username Field Change
2020-10-20 11:34 mohammad New Issue
2020-10-20 11:42 henry Assigned To => henry
2020-10-20 11:42 henry Status new => closed
2020-10-20 11:42 henry Resolution open => unable to reproduce
2020-10-20 11:42 henry Note Added: 0011635