View Issue Details

IDProjectCategoryView StatusLast Update
0003574OpenFOAMFeaturepublic2020-10-17 08:28
Reportersjohn2Assigned Tohenry 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionsuspended 
PlatformLinuxOSUbuntuOS Version20.04
Product Versiondev 
Fixed in Version 
Summary0003574: denseParticleFoam - unaccounted continuous increase in velocities at mesh transition for snappyHexMesh mesh
DescriptionI am simulating droplets flowing out of mouth of a human body, using denseParticleFoam.
The velcoities keeps on increasing at different locations based on mesh transition.
Steps To ReproduceTake a slice at the z direction and on comapring the velicities over different times, concludes that the velocity is increasing at the mesh transitions,
and eventually increasing beyond the inlet velocity
Additional InformationSame problem observed with MPPICFoam
On completely unstructured meshes (tetras), this problem is noticed everywhere in the domain, but doesnot constantly increase.
Problem disappears on the same mesh with pimpleFoam solver.
TagsNo tags attached.

Activities

sjohn2

2020-10-16 00:54

reporter   ~0011615

Is denseParticleFoam only for hexa meshes?

case file attached again below

sjohn2

2020-10-16 01:01

reporter   ~0011616

Link for case file

https://drive.google.com/drive/folders/1aPGem9o1h_tgs8J9vBukTDAwHomMtUvj?usp=sharing

will

2020-10-16 08:42

manager   ~0011617

denseParticleFoam is suitable for all meshes; e.g., the cyclone tutorial.

I suspect that the issue is that the case is largely still with a hydrostatic pressure gradient, but this isn't a p_rgh solver. Hence staggering patterns in the vertical velocity component and some noise on the refinement patterns. Can you try switching gravity off (i.e., set g to (0 0 0)) to confirm it?

sjohn2

2020-10-16 16:40

reporter   ~0011620

It is a p solver. And yes, when you turn gravity off this problem disappears.
However, gravity is important for this case, as I would like to see when the droplets fall into the ground.

henry

2020-10-16 17:18

manager   ~0011621

Can you provide funding to further develop denseParticleFoam for your purpose?

sjohn2

2020-10-16 19:26

reporter   ~0011622

Unfortunately, I am a student and in this COVID times its hard to find funding to sustain my research work.
However just a feedback, this way of modelling gravity term, leaves serious shortcoming on the type of meshes one can have and can be discouraging.
Moreover the gravity effects are required for the particles only, I believe they are insignificant for the continuous field.
I see there is a particle force based on gravity, but I think it takes value of g from the common gravity field.

henry

2020-10-16 20:53

manager   ~0011624

> However just a feedback, this way of modelling gravity term, leaves serious shortcoming on the type of meshes one can have and can be discouraging.

Only for some cases. We would be happy to further develop this solver if anyone is interested enough to fund the work.

sjohn2

2020-10-17 02:23

reporter   ~0011626

Sure. With this issue now identified, hopefully there can be someone who would be interested and can fund this work. On a personal capacity if I can find a work around, I will sure be willing to put forward a patch.

henry

2020-10-17 08:28

manager   ~0011628

Pending funding

Issue History

Date Modified Username Field Change
2020-10-16 00:52 sjohn2 New Issue
2020-10-16 00:54 sjohn2 Note Added: 0011615
2020-10-16 01:01 sjohn2 Note Added: 0011616
2020-10-16 08:42 will Note Added: 0011617
2020-10-16 16:40 sjohn2 Note Added: 0011620
2020-10-16 17:18 henry Note Added: 0011621
2020-10-16 17:32 henry Severity major => feature
2020-10-16 17:32 henry Category Bug => Feature
2020-10-16 19:26 sjohn2 Note Added: 0011622
2020-10-16 20:53 henry Note Added: 0011624
2020-10-17 02:23 sjohn2 Note Added: 0011626
2020-10-17 08:28 henry Assigned To => henry
2020-10-17 08:28 henry Status new => closed
2020-10-17 08:28 henry Resolution open => suspended
2020-10-17 08:28 henry Note Added: 0011628