View Issue Details

IDProjectCategoryView StatusLast Update
0003568OpenFOAMBugpublic2020-10-12 18:23
ReporterjasonAssigned Tohenry 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionno change required 
PlatformLinuxOSUbuntuOS Version18.04
Product Version8 
Fixed in Version 
Summary0003568: multiphaseEulerFoam-unable to select RAS turbulence model for 3-phases
DescriptionWhen RAS is selected for a 3-phase flow, the choice of kEpsilon causes an immediate crash.

#0 Foam::error::printStack(Foam::Ostream&) at ??:?
#1 Foam::sigFpe::sigHandler(int) at ??:?
#2 ? in "/lib/x86_64-linux-gnu/libc.so.6"
#3 Foam::symGaussSeidelSmoother::smooth(Foam::word const&, Foam::Field<double>&, Foam::lduMatrix const&, Foam::Field<double> const&, Foam::FieldField<Foam::Field, double> const&, Foam::UPtrList<Foam::lduInterfaceField const> const&, unsigned char, int) at ??:?
#4 Foam::symGaussSeidelSmoother::smooth(Foam::Field<double>&, Foam::Field<double> const&, unsigned char, int) const at ??:?
#5 Foam::smoothSolver::solve(Foam::Field<double>&, Foam::Field<double> const&, unsigned char) const at ??:?
#6 Foam::fvMatrix<double>::solveSegregated(Foam::dictionary const&) at ??:?
#7 Foam::fvMatrix<double>::solve(Foam::dictionary const&) in "/opt/openfoam8/platforms/linux64GccDPInt32Opt/bin/multiphaseEulerFoam"
#8 Foam::SolverPerformance<double> Foam::solve<double>(Foam::tmp<Foam::fvMatrix<double> > const&) at ??:?
#9 Foam::RASModels::kEpsilon<Foam::PhaseCompressibleMomentumTransportModel<Foam::phaseModel> >::correct() at ??:?
#10 Foam::phaseSystem::correctTurbulence() at ??:?
#11 ? in "/opt/openfoam8/platforms/linux64GccDPInt32Opt/bin/multiphaseEulerFoam"
#12 __libc_start_main in "/lib/x86_64-linux-gnu/libc.so.6"
#13 ? in "/opt/openfoam8/platforms/linux64GccDPInt32Opt/bin/multiphaseEulerFoam"
Floating point exception (core dumped)


Selection of other models LaheyKEpsilon, mixtureKEpsilon, continuousGasKEpsilon the same across all 3-phases or in various configorations cause the following fatal error

--> FOAM FATAL ERROR:
Call from a two-phase model in a multi-phase system.

    From function const Foam::phaseModel& Foam::phaseSystem::otherPhase(const Foam::phaseModel&) const
    in file ../phaseSystems/lnInclude/phaseSystemI.H at line 118.

FOAM exiting
Steps To ReproduceDownload attached simple 2D case, extract, ./Allclean, ./Allrun and inspect the log file
Additional InformationAlso occurs in 3D
TagsNo tags attached.

Activities

jason

2020-10-12 16:01

reporter  

RAS-multiphaseEulerFoam-2D.zip (20,800 bytes)

henry

2020-10-12 16:52

manager   ~0011584

Try the tutorials/multiphase/multiphaseEulerFoam/RAS/bubblePipe

It looks like your case is incorrectly setup and you will need to arrange support.

jason

2020-10-12 17:07

reporter   ~0011585

Hello Henry,

The tutorial bubblePipe has only 2 phases, in addition the gas phase is set to laminar in the tutorial. I have 3 phases all highly dispersed and wanted to have turbulence effects for all phases.

I will try the kOmegaSSTSato with 3-phase and report back and maybe also expand the bubble pipe to 3-phase.

Regards

Jason

jason

2020-10-12 18:15

reporter   ~0011586

I have extended the tutorial multiphase/multiphaseEulerFoam/RAS/bubblePipe to 3 phases. I have set kOmegaSSTSato for both liquids and left the gas phase as it was. Also, split the alpha liquid between the two liquid phases.

If I set the gas phase to laminar the case runs, if I set the gas phase to RAS I get the same error as reported at the end of the first post above

--> FOAM FATAL ERROR:
Call from a two-phase model in a multi-phase system.

    From function const Foam::phaseModel& Foam::phaseSystem::otherPhase(const Foam::phaseModel&) const
    in file ../phaseSystems/lnInclude/phaseSystemI.H at line 118.

FOAM exiting

It seems that I cannot set turbulence for 3-phases

Regards

Jason

bubblePipe-3phase.zip (67,251 bytes)

henry

2020-10-12 18:23

manager   ~0011587

kOmegaSSTSato is specifically a 2-phase model.

henry

2020-10-12 18:23

manager   ~0011588

User support request.

Issue History

Date Modified Username Field Change
2020-10-12 16:01 jason New Issue
2020-10-12 16:01 jason File Added: RAS-multiphaseEulerFoam-2D.zip
2020-10-12 16:52 henry Note Added: 0011584
2020-10-12 17:07 jason Note Added: 0011585
2020-10-12 18:15 jason File Added: bubblePipe-3phase.zip
2020-10-12 18:15 jason Note Added: 0011586
2020-10-12 18:23 henry Note Added: 0011587
2020-10-12 18:23 henry Assigned To => henry
2020-10-12 18:23 henry Status new => closed
2020-10-12 18:23 henry Resolution open => no change required
2020-10-12 18:23 henry Note Added: 0011588