View Issue Details

IDProjectCategoryView StatusLast Update
0003544ThirdPartyPatchpublic2020-09-12 22:16
ReporterGuyAssigned Tohenry 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformLinuxOSCentOSOS Version7.8
Product Version8 
Fixed in Version 
Summary0003544: cmake error (“-lsocket not found”) for Paraview 5.6.3 from OpenFOAM 8 installation on linux
DescriptionHello,
For one of our users I have to install OpenFOAM-8 on a linux cluster running centOS 7.8. This software needs third party’s dependances like Paraview 5.6.3 that are downloaded and installed within OpenFOAM by scripts ( ./makeParaView here for the compilation).
It uses several tools like gcc(10.1 installed), python (3.7.4 installed), cmake (3.18.2 installed), to proceed.
In the output of MakeParaView, the error message is

Determining if the function getsockname exists in the socket failed with the following output:
Change Dir: <DIR>/OpenFOAM/ThirdParty-8/build/linux64Gcc/ParaView-5.6.3/CMakeFiles/CMakeTmp

Run Build Command(s):/usr/bin/gmake cmTC_63115/fast && /usr/bin/gmake -f CMakeFiles/cmTC_63115.dir/build.make CMakeFiles/cmTC_63115.dir/build
gmake[1] : entering directory «<DIR>/OpenFOAM/ThirdParty-8/build/linux64Gcc/ParaView-5.6.3/CMakeFiles/CMakeTmp »
Building C object CMakeFiles/cmTC_63115.dir/CheckFunctionExists.c.o
gcc -DCHECK_FUNCTION_EXISTS=getsockname -o CMakeFiles/cmTC_63115.dir/CheckFunctionExists.c.o -c <DIR>/cmake/3.18.2/share/cmake-3.18/Modules/CheckFunctionExists.c
Linking C executable cmTC_63115
<DIR>/cmake/3.18.2/bin/cmake -E cmake_link_script CMakeFiles/cmTC_63115.dir/link.txt --verbose=1
gcc -DCHECK_FUNCTION_EXISTS=getsockname -Wl,-lc -Wl,-lc CMakeFiles/cmTC_63115.dir/CheckFunctionExists.c.o -o cmTC_63115 -lsocket
/usr/bin/ld : -lsocket not found
collect2: error: ld returns error code 1
gmake[1]: *** [cmTC_63115] Error 1
gmake[1] : leaving directory «<DIR>/OpenFOAM/ThirdParty-8/build/linux64Gcc/ParaView-5.6.3/CMakeFiles/CMakeTmp »
gmake: *** [cmTC_63115/fast] Error 2
N.B. : We are not running anything related to BSD or FreeBSD, so I do not understand why I need -lsocket.
The different tools (gcc, cmake, python, …) used here are compiled from source directly on the cluster, no binary installed.

Thank you for your help.
Regards
Guy.
Steps To ReproduceThe compiling environment is set through modules, so
"module load gcc/10.1 python/3.7.4 openmpi/psm2/gcc101/4.0.3 cmake/3.18.2"
for GNU gcc 10.1, Python 3.7.4, OpenMPI 4.0.3, make 3.18.2
(all these tools have been hand compiled)

For OpenFOAM environment I run the script
"source OpenFOAM/OpenFOAM-8/etc/bashrc"

I launch the script ./makeParaView
TagsNo tags attached.

Activities

henry

2020-09-04 14:37

manager   ~0011491

Do you have the socket library installed and if not have you tried installing it?

Guy

2020-09-04 15:05

reporter   ~0011492

I do not need it and it's included by default in the libc on CentOS. I do not find it apart, so I cant install it even if i want to.

henry

2020-09-04 15:14

manager   ~0011493

It is not clear why ParaView needs the socket library and this is not under our control as we are not the maintainers of ParaView. Try contacting KitWare for help with this.

Guy

2020-09-04 15:24

reporter   ~0011494

This is exactly what people of ParaView told me this afternoon but in the other way.

henry

2020-09-04 15:45

manager   ~0011495

There is no reference to the socket library in any of our code or build system. If you think there might be an issue with the makeParaView script try building paraview directly. We are not able to reproduce the problem on any of our systems. Alternatively try building an older or newer version of ParaView to see if it suffers from the same problem.

Guy

2020-09-04 16:09

reporter   ~0011496

OK, thank you for your messages. I'll try.

Issue History

Date Modified Username Field Change
2020-09-04 14:29 Guy New Issue
2020-09-04 14:37 henry Note Added: 0011491
2020-09-04 15:05 Guy Note Added: 0011492
2020-09-04 15:14 henry Note Added: 0011493
2020-09-04 15:24 Guy Note Added: 0011494
2020-09-04 15:45 henry Note Added: 0011495
2020-09-04 16:09 Guy Note Added: 0011496
2020-09-12 22:16 henry Assigned To => henry
2020-09-12 22:16 henry Status new => closed
2020-09-12 22:16 henry Resolution open => unable to reproduce