View Issue Details

IDProjectCategoryView StatusLast Update
0003542OpenFOAMFeaturepublic2020-08-31 13:06
ReporterpeksaAssigned Tohenry 
PrioritylowSeverityfeatureReproducibilityalways
Status closedResolutionno change required 
PlatformGNU/LinuxOSUbuntuOS Version15.04
Product Version8 
Fixed in Version 
Summary0003542: Consistent SIMPLE(C) not available in lagrangian PIMPLE-based solvers
DescriptionDear developers,

I was wondering whether there is a particular reason for lagrangian solver class not to support consistent SIMPLE (SIMPLEC) approach within the PIMPLE pressure coupling. I don't consider it a must feature but I'm interested to hear whether it is a rational decision and perhaps related to lagrangian source terms?

Actually, I first noticed this because I was using a consistent keywork in fvSolution but didn't see any difference in solver performace. Perhaps a Warning message could be added to solvers which are not supporting SIMPLEC to prevent user misunderstandings / mistakes.

-- peksa
Steps To ReproduceSee e.g. sprayFoam solver pEqn.H
TagsNo tags attached.

Activities

henry

2020-08-31 09:37

manager   ~0011480

Last edited: 2020-08-31 09:46

View 2 revisions

We don't have any Lagrangian cases for which it would be clearly beneficial.

> Perhaps a Warning message could be added to solvers which are not supporting SIMPLEC to prevent user misunderstandings / mistakes.

It would a substantial undertaking to add and maintain warning messages about functionality not present in all solvers.

peksa

2020-08-31 09:49

reporter   ~0011481

I agree with you, haven't seen any clear benefits either. Thank you for clarification.

Issue History

Date Modified Username Field Change
2020-08-31 09:30 peksa New Issue
2020-08-31 09:37 henry Note Added: 0011480
2020-08-31 09:46 henry Note Edited: 0011480 View Revisions
2020-08-31 09:49 peksa Note Added: 0011481
2020-08-31 13:06 henry Assigned To => henry
2020-08-31 13:06 henry Status new => closed
2020-08-31 13:06 henry Resolution open => no change required