View Issue Details

IDProjectCategoryView StatusLast Update
0003540OpenFOAMBugpublic2020-09-01 16:48
ReporterStefan BoskovicAssigned Tohenry 
PrioritynormalSeveritycrashReproducibilityN/A
Status closedResolutionno change required 
Product Version8 
Fixed in Version8 
Summary0003540: Continued filling of RAM with (M)PLIC(U)
DescriptionHello,

I encountered continued filling of the RAM and swap (pagefile) memory on Ubuntu 16.04 when I used (M)PLIC(U), while I didn't have problems with interfaceCompression.

Best regards,
Stefan Bošković
Steps To ReproduceIt can be seen on the damBreak case when you put (for example) MPLIC and change maxCo to 0.01 or lower so that there are many time steps. Maybe some pointer is created in every time step with "New" and not deleted?
Additional InformationBecause of this problem, usability of (M)PLIC(U) for calculations that last more than 20 minutes is questionable.
TagsNo tags attached.

Activities

henry

2020-08-29 17:12

manager   ~0011479

This has already been fixed, try the latest OpenFOAM-8 or OpenFOAM-dev

Stefan Boskovic

2020-08-31 10:58

reporter   ~0011482

OK, thank you. I installed OpenFOAM-8 few days ago through the repository, so maybe we need OpenFOAM-dev at the moment. Maybe it would be nice if you could make a patch.

henry

2020-08-31 12:12

manager   ~0011483

You can easily make a patch from the git repository or simple pull the complete source of either OpenFOAM-8 or OpenFOAM-dev.

Stefan Boskovic

2020-09-01 11:48

reporter   ~0011484

OK, thank you, I might try to use the OpenFOAM-dev. Also, maybe it would be useful for you to update before people that use HPCs or other people see this problem.

henry

2020-09-01 16:48

manager   ~0011485

Already resolved in OpenFOAM-8 and dev.

Issue History

Date Modified Username Field Change
2020-08-29 15:57 Stefan Boskovic New Issue
2020-08-29 17:12 henry Note Added: 0011479
2020-08-31 10:58 Stefan Boskovic Note Added: 0011482
2020-08-31 12:12 henry Note Added: 0011483
2020-09-01 11:48 Stefan Boskovic Note Added: 0011484
2020-09-01 16:48 henry Assigned To => henry
2020-09-01 16:48 henry Status new => closed
2020-09-01 16:48 henry Resolution open => no change required
2020-09-01 16:48 henry Fixed in Version => 8
2020-09-01 16:48 henry Note Added: 0011485