View Issue Details

IDProjectCategoryView StatusLast Update
0003529OpenFOAMBugpublic2020-08-11 10:39
ReporterSidAssigned Towill 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
PlatformGNU/LinuxOSOpenSuSEOS Version13.2
Product Versiondev 
Fixed in Version 
Summary0003529: Barycentric tracking in moving meshes seems to show erroneous patch
DescriptionDear team,

I am testing the new Barycentric tracking in moving mesh. For that I used the column tutorial with MPPICDyFoam. I used
staticFvMesh and a dynamicMotionSolverFvMesh with a extremely low motion. The idea is to use the dynamic tracking functions in the particle.H.

Please see the attached videos for both cases. In the moving mesh case. the particle path is quiet erratic. The case is attached. All the MPPIC sub-models are off. And a single particle is injected.

I've debugged the tracking algorithm, while I can make sense of the static mesh tracking , the moving one is a bit more challenging as I don't have any reference from where this formulation comes. I could dig more into this if I had some reference
to follow.

Thanks
TagsNo tags attached.

Activities

Sid

2020-08-07 16:18

reporter  

column.tar (122,880 bytes)
staticMesh.mp4 (28,868 bytes)
movingMesh.mp4 (32,240 bytes)

will

2020-08-08 16:28

manager   ~0011448

MPPICDyMFoam hasn't existed since version 6. It was deleted when dynamic mesh support was added to MPPICFoam, and then recently DPMFoam and MPPICFoam were replaced by denseParticleFoam.

I can't run your case. Obviously it doesn't run in dev, but even using MPPICDyMFoam in versions 5 and 6 your case doesn't run. Which version of OpenFOAM are you using?

Sid

2020-08-10 17:22

reporter   ~0011451

Hi Will,

I am using a combination of different versions which best fit my needs. As you can see I used the column tutorial which now under denseParticleFoam. I haven't pulled the latest dev as there are too many changes to track. But , I am tracking all the new bug fixes in the lagragian particle tracking library. After a few test/debug making the column tutorial to use dynamicMesh gives some erroneous particle path. I am quiet sure the problem lies in trackToMovingTri. I pulled the latest changes to handle detA < 0.
In the tutorial I switched all the MPPIC sub-models off and I just do the tracking.

Thanks

will

2020-08-11 10:38

manager   ~0011452

It works fine in dev and 8. See attached. I would assume that you have made a mistake in creating "a combination of different versions which best fit my needs". Closing.

column-dev.tar.gz (14,788 bytes)

Issue History

Date Modified Username Field Change
2020-08-07 16:18 Sid New Issue
2020-08-07 16:18 Sid File Added: column.tar
2020-08-07 16:18 Sid File Added: staticMesh.mp4
2020-08-07 16:18 Sid File Added: movingMesh.mp4
2020-08-08 16:28 will Note Added: 0011448
2020-08-10 17:22 Sid Note Added: 0011451
2020-08-11 10:38 will File Added: column-dev.tar.gz
2020-08-11 10:38 will File Added: column-dev_particleTracks_zScale=0.1.png
2020-08-11 10:38 will Note Added: 0011452
2020-08-11 10:38 will Assigned To => will
2020-08-11 10:38 will Status new => closed
2020-08-11 10:38 will Resolution open => fixed
2020-08-11 10:39 will Resolution fixed => no change required
2020-08-11 10:39 will Description Updated View Revisions