View Issue Details

IDProjectCategoryView StatusLast Update
0003515OpenFOAMContributionpublic2020-07-01 15:56
ReporterlorenzotrevisanAssigned Tohenry 
PrioritylowSeverityfeatureReproducibilityalways
Status closedResolutionno change required 
Platformx86_64OSSlackwareOS Version14.2
Product Version7 
Fixed in Version 
Summary0003515: Support request about a proposal of fvOptions solidificationMeltingSource for irreversible phase change
Descriptioncurrent fvOptions solidificationMeltingSource allows only reversible phase change namely at equilibrium temperatures without irreversible solidification undercooling.
Thermal analysis highlights an undercooling as activation energy to get the solidification started, and a trend to restore equilibrium temperature.
Focusing on Sn-Pb alloy characteristic hypo, hyper and eutectic behavior it seems to me to be fine the results obtained considering appropriate calibration coefficients irrM (to control undercooling magnitude) and irrR (to control reheating rate), such that irrM is proportional to time average cooling rate and irrR is function of volume average melt fraction.
During development I was not able to consider the heating/cooling rate (dotT) in a smart way (as fvc::ddt(T) should allow), so I am primarily asking for support about it: please let see comment at row 151 and my workaround from row 200 of meltingSolidificationSource.C.
Steps To Reproduce1- compile fvOptions substituting attached files in fvOptions/sources/derived/solidificationMeltingSource/

2- case definition requires a new additional syntax for fvOptions dictionary in order to consider solidification irreversibility:
    i- optionally use irrMsol and/or irrMliq to calibrate undercooling magnitude respectively for eutectic and primary solidification;
   ii- optionally use irrRsol and/or irrRliq to calibrate reheating(recalescence) rate respectively for eutectic and primary solidification;
  iii- the attached implementation become unstable for heavy undercooling due to initial dotT calculation, so use Tstart in fvOption dictionary in order to delay the irreversible solidification calculation start.
Additional Information    +- I aspect Lirr < Lrev = L (latent heat)
  ++- I’m testing a model to control nucleation delay
+++- I aspect irrM is a characteristic time proportional to: (dM^2)/(lambda/Cp*rho) | M=Volume/Area
TagsNo tags attached.

Activities

lorenzotrevisan

2020-07-01 15:23

reporter  

solidificationMeltingSource-v7-recalescence.tar.gz (6,811 bytes)

henry

2020-07-01 15:56

manager   ~0011412

User support request, you will need to arrange a support contract to cover this.

Issue History

Date Modified Username Field Change
2020-07-01 15:23 lorenzotrevisan New Issue
2020-07-01 15:23 lorenzotrevisan File Added: solidificationMeltingSource-v7-recalescence.tar.gz
2020-07-01 15:56 henry Assigned To => henry
2020-07-01 15:56 henry Status new => closed
2020-07-01 15:56 henry Resolution open => no change required
2020-07-01 15:56 henry Note Added: 0011412