View Issue Details

IDProjectCategoryView StatusLast Update
0003513OpenFOAMBugpublic2020-06-23 15:43
ReporterjoegiAssigned Towill 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformOpenSUSE 15OSOS Version
Product Version7 
Fixed in Versiondev 
Summary0003513: pimpleFoam - residualControl does not have any effect when using the functionOnject scalarTransport
DescriptionIn report 0003510, the issue with steady solvers was fixed. Now it works great.

Now I am doing the same test with unsteady solvers and I found that the issue is still there.

Personally speaking, for unsteady solvers this is not a big deal (my opinion). However, I think it is a good idea to have a consistent behavior among the solvers.

If you set outerCorrectorResidualControl to a large value, i.e.,

    outerCorrectorResidualControl
    {
        "(T)"
        {
            relTol 1; //0.01 - 0.001
            tolerance 1; //0.001 - 0.0001
        }
    }

I would expect the loop to stop almost immediately, but it does not.

I also found that if you use residualControl, the solver will read this condition as well.

    residualControl
    {
        T 1;
    }

I think the use of residualControl is redundant. The condition outerCorrectorResidualControl should be enough to control the loop. In my personal opinion, residualControl makes sense only to assess if the solver has reached a steady behavior (maybe this is the desired behavior, I don't know).

Maybe a way to solve this issue, will be to add the tolerance in the function object scalarTransport, but this fix will be only valid for this specific function object.

Again, I think this is more an annoying behavior than a bug.
Steps To ReproduceIn the attached case run the script run_all.sh:

$> sh run_all.sh

The tolerance of the transported scalar is high, so I would expect the solver to stop immediacy, but it does not.
TagsNo tags attached.

Relationships

duplicate of 0003336 resolvedwill Purpose of residualControl in the pimple loop 

Activities

joegi

2020-06-23 13:34

reporter  

pimpleFoam.tar.gz (31,211 bytes)

will

2020-06-23 15:43

manager   ~0011409

PimpleFoam in version 7 does not support time-loop residualControl. This has already been resolved in dev.

Issue History

Date Modified Username Field Change
2020-06-23 13:34 joegi New Issue
2020-06-23 13:34 joegi File Added: pimpleFoam.tar.gz
2020-06-23 15:42 will Relationship added duplicate of 0003336
2020-06-23 15:43 will Assigned To => will
2020-06-23 15:43 will Status new => resolved
2020-06-23 15:43 will Resolution open => duplicate
2020-06-23 15:43 will Fixed in Version => dev
2020-06-23 15:43 will Note Added: 0011409