View Issue Details

IDProjectCategoryView StatusLast Update
0003512OpenFOAMBugpublic2020-06-23 11:58
ReporterSamMallinsonAssigned Towill 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformLinuxOSUbuntuOS Version18.04
Product Version7 
Fixed in Version 
Summary0003512: Cylinder tutorial for reactingParcelFoam does not run in parallel
DescriptionIf I modify the reactingParcelFoam tutorial cylinder to run in multiprocessor mode, then it fails to run.

I modify the Allrun script, replacing:

runApplication $application

with:

runApplication decomposePar
runParallel $application

and I modify system/decomposeParDict to use simple method (I do not have metis installed)

The error is as follows:

Selecting injection model reactingMultiphaseLookupTableInjection
    Constructing 3-D injection
[0]
[0]
[0] --> FOAM FATAL ERROR:
[0] cannot find file "/home/samuel/projects/rpftest/cylinder/processor0/constant/parcelInjectionProperties"
[1]
[1]
[1] --> FOAM FATAL ERROR:
[1] cannot find file "/home/samuel/projects/rpftest/cylinder/processor1/constant/parcelInjectionProperties"
[1]
[1] From function virtual Foam::autoPtr<Foam::ISstream> Foam::fileOperations::uncollatedFileOperation::readStream(Foam::regIOobject&, const Foam::fileName&, const Foam::word&, bool) const
[1] in file global/fileOperations/uncollatedFileOperation/uncollatedFileOperation.C at line 538.
[1]
FOAM parallel run exiting
[1]
[0]
[0] From function virtual Foam::autoPtr<Foam::ISstream> Foam::fileOperations::uncollatedFileOperation::readStream(Foam::regIOobject&, const Foam::fileName&, const Foam::word&, bool) const
[0] in file global/fileOperations/uncollatedFileOperation/uncollatedFileOperation.C at line 538.
[0]
FOAM parallel run exiting
Steps To Reproducedownload attached tar ball and extract using tar xvf cylinder.tar
source /path/to/OpenFOAM-7/etc/bashrc
./Allclean
./Allrun
Additional InformationI think this has something to do with the InjectionModel type, reactingMultiphaseLookupTableInjection.

I have seen the same errors when I try to change another functioning case which uses patchInjection to use reactingMultiphaseLookupTableInjection. The same case runs fine in single processor mode.
TagsNo tags attached.

Activities

SamMallinson

2020-06-23 08:05

reporter  

cylinder.tar (92,160 bytes)

will

2020-06-23 08:50

manager   ~0011405

I can't reproduce this in version 7. When I run your case it gives me a different error as you have not decomposed the wall film region. If I add decomposition of the wall film region, the case runs without error.

will

2020-06-23 11:58

manager   ~0011407

Not able to reproduce.

Issue History

Date Modified Username Field Change
2020-06-23 08:05 SamMallinson New Issue
2020-06-23 08:05 SamMallinson File Added: cylinder.tar
2020-06-23 08:50 will Note Added: 0011405
2020-06-23 11:58 will Assigned To => will
2020-06-23 11:58 will Status new => closed
2020-06-23 11:58 will Resolution open => unable to reproduce
2020-06-23 11:58 will Note Added: 0011407