View Issue Details

IDProjectCategoryView StatusLast Update
0003511OpenFOAMFeaturepublic2020-06-23 13:39
ReporterlampssAssigned Tohenry 
PrioritynoneSeveritycrashReproducibilityalways
Status closedResolutionsuspended 
PlatformWindows Subsystem for LinuxOSUbuntuOS Version16.04.6 LTS
Product Version6 
Fixed in Version 
Summary0003511: fluent3DMeshToFoam crashes while generating multidomain mesh from Fluent Meshing
DescriptionLately I've been using relatively new ANSYS feature - Fluent Meshing. Converting the mesh ( in ASCII format) using fluent3DMeshToFoam was working fine when the model was a single domain - even polyhedral mesh converts properly. However, problem occurs when there are several domains (cell zones) in the model. In such case fluent3DMeshToFoam crashes - please see the attached log file.
Steps To Reproduce- create geometry (in SpaceCaim) with several cell zones and shared surfaces in between
- generate the mesh (polyhedral, tetrahedral - no matter which type) using Fluent Meshing
- write msh file in ASCII (without binary files)
- run fluent3DMeshToFoam
Additional InformationI use OpenFOAM v5 - couldn't choose this one under "Product Version"
TagsNo tags attached.

Activities

lampss

2020-06-22 13:58

reporter  

fluent3DMeshToFoam.log (481,806 bytes)

henry

2020-06-22 14:04

manager   ~0011402

> However, problem occurs when there are several domains (cell zones) in the model. In such case fluent3DMeshToFoam crashes

fluent3DMeshToFoam does not currently support this, can you provide a patch to add this functionality or sponsor the development?
Alternatively you could use snappyHexMesh instead.

lampss

2020-06-22 14:46

reporter   ~0011403

Actually I would say that fluent3DMeshToFoam seems to support this - mesh with many fluid cell zones generated in ANSYS Workbench works fine. Hence was my question - I thought that this is maybe just a difference in mesh definition due to the different meshing software (Ansys Meshing instead of Workbench).

henry

2020-06-22 15:34

manager   ~0011404

Maybe, we don't have access to either to check for you. If you can provide a patch to fluent3DMeshToFoam to handle your cases we can look into merging it, or if you would like to sponsor further development of fluent3DMeshToFoam let us know.

henry

2020-06-23 13:39

manager   ~0011408

Pending funding or a patch.

Issue History

Date Modified Username Field Change
2020-06-22 13:58 lampss New Issue
2020-06-22 13:58 lampss File Added: fluent3DMeshToFoam.log
2020-06-22 14:04 henry Note Added: 0011402
2020-06-22 14:46 lampss Note Added: 0011403
2020-06-22 15:34 henry Note Added: 0011404
2020-06-22 15:35 henry Priority urgent => none
2020-06-22 15:35 henry Category Bug => Feature
2020-06-22 15:35 henry Steps to Reproduce Updated View Revisions
2020-06-23 13:39 henry Assigned To => henry
2020-06-23 13:39 henry Status new => closed
2020-06-23 13:39 henry Resolution open => suspended
2020-06-23 13:39 henry Note Added: 0011408