View Issue Details

IDProjectCategoryView StatusLast Update
0003507OpenFOAMBugpublic2020-06-09 11:56
ReporteryeharavAssigned Tohenry 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
PlatformUnixOSUbuntu OS Version18.05
Product Version7 
Fixed in Version 
Summary0003507: Spurious results in parallel run with 1 or more cyclic when inspected with paraFoam
DescriptionSpurious modes in the pressure or velocity when running pimpleFoam or buoyantPimpleFoam with
cyclic boundaries.

The spurious modes appear in the boundaries between the processors.

In the 1 cyclic case, the spurious modes disappear after reconstruction.
In the 2 cyclic case, the spurious modes persist (but dumped) after reconstruction.
Steps To ReproduceFor pimpleFoam:
1. Copy the channel395 tutorial.
2. Edit the decpompose par dict to preserve faces on cyclic case.
3. run parallel.

For the buoyantPimpleFoam:
1. Copy the hotroom example.
2. Edit the decpompose par dict to preserve faces on cyclic case.
3. Change the walls to be cyclic (separate the different walls).
4. run parallel.

Additional InformationWe have uploaded the case files with the spurious modes as well as an example of the modes.

For simplicity, we have changed the channel example to contain a single hexblock.

For the buoyant case, run with ./Allrun.
TagsNo tags attached.

Activities

yeharav

2020-06-08 09:17

reporter  

Ux_400s_hotroom_cylic.png (30,231 bytes)
Ux_400s_hotroom_cylic.png (30,231 bytes)
buoyant.zip (369,832 bytes)

henry

2020-06-08 09:30

manager   ~0011381

Do you have cyclic patches normal to the direction of gravity?

yeharav

2020-06-08 09:54

reporter   ~0011382

No, in this example the cyclic is only in the z-normal direction.
In pimple foam there is no buoyancy

henry

2020-06-08 11:14

manager   ~0011384

I just ran the case you provided and get the attached result for Ux (cell values and interpolated values) on the centre cutting plane at 400s

yeharav

2020-06-08 12:07

reporter   ~0011385

I will rerun my example in a different environment. Maybe it is an installation problem.

yeharav

2020-06-09 05:29

reporter   ~0011386

I tried on a different installation (same version) and got the same results. Did you use Paraview 5.6
and showed the deconstructed results? (using paraFoam -builtin?).

henry

2020-06-09 08:46

manager   ~0011387

> Did you use Paraview 5.6

Yes

> using paraFoam -builtin?

No, I use the OpenFOAM reader we release with OpenFOAM.

We are not involved in the maintenance of the OpenFOAM reader released by KitWare, you will need to report any issues you have with it to them.

yeharav

2020-06-09 11:41

reporter   ~0011391

I see, so you have reconstructed your solution, and like us have no problem.

The problem is that when the simulation is large it is not possible to process it with a single processor
(and it is very time consuming to reconstruct).

Do you have any advice on how to process parallel solutions?

henry

2020-06-09 11:55

manager   ~0011392

Report the problem to KitWare to see if they will fix the bug in their OpenFOAM reader.

Visualise cell data rather than interpolated data.

Generate point data in parallel during the OpenFOAM run and read that (assuming the KitWare reader supports it).

Post-process the results in parallel in OpenFOAM either during the run of afterwards using the many functionObjects we provide:
https://cfd.direct/openfoam/user-guide/v7-post-processing-cli/#x32-2390006.2
https://cfd.direct/openfoam/user-guide/v7-graphs-monitoring/#x33-2550006.3

henry

2020-06-09 11:56

manager   ~0011393

The issue is a bug in the KitWare ParaView reader module rather than in OpenFOAM.

Issue History

Date Modified Username Field Change
2020-06-08 09:17 yeharav New Issue
2020-06-08 09:17 yeharav File Added: Ux_400s_hotroom_cylic.png
2020-06-08 09:17 yeharav File Added: Ux_400s_hotroom_cylic_parallel.png
2020-06-08 09:17 yeharav File Added: buoyant.zip
2020-06-08 09:30 henry Note Added: 0011381
2020-06-08 09:54 yeharav Note Added: 0011382
2020-06-08 10:27 henry File Added: Ux_400s_hotroom_cyclic_parallel.png
2020-06-08 11:13 henry File Deleted: Ux_400s_hotroom_cyclic_parallel.png
2020-06-08 11:14 henry File Added: Ux_400s_hotroom_cyclic_parallel.png
2020-06-08 11:14 henry File Added: Uxp_400s_hotroom_cyclic_parallel.png
2020-06-08 11:14 henry Note Added: 0011384
2020-06-08 12:07 yeharav Note Added: 0011385
2020-06-09 05:29 yeharav Note Added: 0011386
2020-06-09 08:46 henry Note Added: 0011387
2020-06-09 11:41 yeharav Note Added: 0011391
2020-06-09 11:55 henry Note Added: 0011392
2020-06-09 11:56 henry Assigned To => henry
2020-06-09 11:56 henry Status new => closed
2020-06-09 11:56 henry Resolution open => no change required
2020-06-09 11:56 henry Note Added: 0011393