View Issue Details

IDProjectCategoryView StatusLast Update
0003505OpenFOAMBugpublic2020-06-09 09:00
ReporterSamMallinsonAssigned Towill 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformLinuxOSUbuntu and DebianOS Version18.04 and sid
Product Version7 
Fixed in Version 
Summary0003505: lineCell sampling changes detected cells in version 7
DescriptionThis is a side issue from https://bugs.openfoam.org/view.php?id=3504, which had the example of a planar 2D channel with one wall attached to a heated plate

When going from version 6 to version 7, the number of points detected using the lineCell method changes.

The mesh used is very simple: a rectangular prism with 100x15x1 cells, with the domain split in the y-direction with the upper 10 cells being the fluid (liquid) and the lower 5 the solid (heater).

In version 6, 15 y-locations are output, whereas in version 7, the cell in the heater layer adjacent to the liquid is not detected. See

https://bugs.openfoam.org/file_download.php?file_id=2987&type=bug

and

https://bugs.openfoam.org/file_download.php?file_id=2989&type=bug

I think this might have arisen due to changes in the lineFace code, which is #include'd in lineCell.H, but I could not identify the commit where this change happened.
Steps To ReproduceFor version 6:
- download chtPlate_of6.tar, see https://bugs.openfoam.org/file_download.php?file_id=2991&type=bug, un-tar it, call foam-bash-6 (. ~/pathTo/OpenFoam-6/etc/bashrc) then ./Allrun

For version 7:
- download chtPlate_of7.tar, see https://bugs.openfoam.org/file_download.php?file_id=2990&type=bug, un-tar it, call foam-bash-7 (. ~/pathTo/OpenFoam-6/etc/bashrc) then ./Allrun

NB: the plotting routine in the folder plots requires python3 with numpy pylab os and sys installed. You can always just inspect the values in postProcessing/singleGraph0/liquid/<iteration>/line_T.xy and postProcessing/singleGraph1/heater/<iteration>/line_T.xy, where <iteration> is the number of iterations to converge which may vary from system to system.

TagsNo tags attached.

Activities

will

2020-06-09 09:00

manager   ~0011388

The heater graph line is exactly on a boundary, and the start and end points are exactly on an edge. Sampling lines have to unambiguously intersect the cells, or what points you get out aren't well defined. The fact that there's a difference between versions is just a fluke. A start and end of (0.9999 -0.1001 5e-3) and (0.9999 -0.0499 5e-3) works fine.

Issue History

Date Modified Username Field Change
2020-06-04 05:51 SamMallinson New Issue
2020-06-09 09:00 will Assigned To => will
2020-06-09 09:00 will Status new => closed
2020-06-09 09:00 will Resolution open => no change required
2020-06-09 09:00 will Note Added: 0011388