View Issue Details

IDProjectCategoryView StatusLast Update
0003501OpenFOAMBugpublic2020-06-02 18:45
Reporterdl6tudAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformGNU/LinuxOSOtherOS Version(please specify)
Product Version7 
Fixed in Versiondev 
Summary0003501: bug patchToPatchInterpolation.H
Description/src/OpenFOAM/interpolations/patchToPatchInterpolation/patchToPatchInterpolation.H

namespace Foam
{
    typedef PatchToPatchInterpolation
    <
        PrimitivePatch<face, SubList, const pointField&>,
        PrimitivePatch<face, SubList, const pointField&>
    > patchToPatchInterpolation;
}

SHOULD READ:

namespace Foam
{
    typedef PatchToPatchInterpolation
    <
        PrimitivePatch<SubList<face>, const pointField&>,
        PrimitivePatch<SubList<face>, const pointField&>
    > patchToPatchInterpolation;
}
TagsNo tags attached.

Relationships

duplicate of 0003463 resolvedhenry Incorrect template for PrimitivePatch in patchToPatchInterpolation.H 

Activities

henry

2020-06-02 18:45

manager   ~0011370

commit 58f3ed727678475f6970b5a8190c5b3695c893b8 (tag: 20200301)
Author: Henry Weller <http://openfoam.org>
Date: Sat Feb 29 15:12:31 2020 +0000

    patchToPatchInterpolation: Updated typedef to correspond to new definition of PrimitivePatch
    
    Resolves bug-report https://bugs.openfoam.org/view.php?id=3463

Issue History

Date Modified Username Field Change
2020-06-02 18:24 dl6tud New Issue
2020-06-02 18:45 henry Assigned To => henry
2020-06-02 18:45 henry Status new => closed
2020-06-02 18:45 henry Resolution open => duplicate
2020-06-02 18:45 henry Fixed in Version => dev
2020-06-02 18:45 henry Note Added: 0011370
2020-06-02 18:45 henry Relationship added duplicate of 0003463