View Issue Details

IDProjectCategoryView StatusLast Update
0003497OpenFOAMBugpublic2020-05-18 15:44
ReporterJeroenJanssenAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version20.04
Product Versiondev 
Fixed in Versiondev 
Summary0003497: blockMeshDict missing in pitzDaily tutorial
DescriptionHi,
I just installed a clean version of OF dev and while going through the steps on your website for checking if the installation went correct, I noticed that the blockMeshDict file is missing in the $FOAM_TUTORIAL/incompressible/simpleFoam/pitzDaily/system folder. (it's also missing on the GitHub repo)

I created a new blockMeshDict from the previous version, and everything seems to works ok.

Thanks,
Jeroen
Steps To Reproduceinstall OF-dev

cd $FOAM_RUN
cp -r $FOAM_TUTORIALS/incompressible/simpleFoam/pitzDaily .
cd pitzDaily
blockMesh
TagsNo tags attached.

Activities

tniemi

2020-05-17 19:57

reporter   ~0011350

Hi,

In the pitzDaily case there is Allrun-script, which contains this:
runApplication blockMesh -dict $FOAM_TUTORIALS/resources/blockMesh/pitzDaily

So the blockMesh is located in a common resources folder, because there are multiple variations of the same tutorial for differents solvers.

JeroenJanssen

2020-05-18 10:36

reporter   ~0011351

Hi,

Thanks, ok, that makes sense.
Maybe then the steps on the website should be updated to reflect that (as that is now the new steps to get the dev-version to work..)

https://openfoam.org/download/dev-ubuntu/
Under 'Getting Started'

Many thanks!

henry

2020-05-18 15:44

manager   ~0011353

Resolved by commit 1217724ed93a0e6906eedcf4b022c940c35d91ee

Issue History

Date Modified Username Field Change
2020-05-17 19:16 JeroenJanssen New Issue
2020-05-17 19:57 tniemi Note Added: 0011350
2020-05-18 10:36 JeroenJanssen Note Added: 0011351
2020-05-18 15:44 henry Assigned To => henry
2020-05-18 15:44 henry Status new => resolved
2020-05-18 15:44 henry Resolution open => fixed
2020-05-18 15:44 henry Fixed in Version => dev
2020-05-18 15:44 henry Note Added: 0011353