View Issue Details

IDProjectCategoryView StatusLast Update
0003496OpenFOAMBugpublic2020-06-01 11:21
ReportergskillasAssigned Towill 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformGNU/LinuxOSOpenSuSE LeapOS Version15.1
Product Versiondev 
Fixed in Version 
Summary0003496: foamyHexMesh does not compile, failing CGAL include
DescriptionUsing CGAL 5.0.2 after the latest changes compilation of foamy fails:

g++ -std=c++11 -m64 -Dlinux64 -DWM_ARCH_OPTION=64 -DWM_DP -DWM_LABEL_SIZE=32 -Wall -Wextra -Wold-style-cast -Wnon-virtual-dtor -Wno-unused-parameter -Wno-invalid-offsetof -Wno-attributes -O3 -DNoRepository -ftemplate-depth-100 -frounding-math -DNDEBUG -DCGAL_INEXACT -std=c++14 -DCGAL_NO_DEPRECATED_CODE -DCGAL_HEADER_ONLY -I/home/cfd/OpenFOAM/ThirdParty-dev/CGAL-5.0.2/include -Wno-old-style-cast -Wno-unused-local-typedefs -Wno-array-bounds -I/home/cfd/OpenFOAM/OpenFOAM-dev/src/finiteVolume/lnInclude -I/home/cfd/OpenFOAM/OpenFOAM-dev/src/meshTools/lnInclude -I/home/cfd/OpenFOAM/OpenFOAM-dev/src/parallel/decompose/decompositionMethods/lnInclude -I/home/cfd/OpenFOAM/OpenFOAM-dev/src/fileFormats/lnInclude -I/home/cfd/OpenFOAM/OpenFOAM-dev/src/dynamicMesh/lnInclude -I/home/cfd/OpenFOAM/OpenFOAM-dev/src/surfMesh/lnInclude -I/home/cfd/OpenFOAM/OpenFOAM-dev/src/triSurface/lnInclude -I/home/cfd/OpenFOAM/OpenFOAM-dev/src/sampling/lnInclude -I/home/cfd/OpenFOAM/OpenFOAM-dev/src/mesh/snappyHexMesh/lnInclude -IPrintTable -IlnInclude -I. -I/home/cfd/OpenFOAM/OpenFOAM-dev/src/OpenFOAM/lnInclude -I/home/cfd/OpenFOAM/OpenFOAM-dev/src/OSspecific/POSIX/lnInclude -fPIC -c conformalVoronoiMesh/featurePointConformer/pointFeatureEdgesTypes.C -o /home/cfd/OpenFOAM/OpenFOAM-dev/platforms/linux64GccDPInt32Opt/applications/utilities/mesh/generation/foamyMesh/conformalVoronoiMesh/conformalVoronoiMesh/featurePointConformer/pointFeatureEdgesTypes.o
In file included from lnInclude/CGALTriangulation3Ddefs.H:44:0,
                 from DelaunayMeshTools/DelaunayMeshTools.H:45,
                 from DelaunayMeshTools/DelaunayMeshTools.C:26:
lnInclude/indexedCell.H:41:10: fatal error: CGAL/Delaunay_triangulation_cell_base_with_circumcenter_3.h: No such file or directory
 #include "CGAL/Delaunay_triangulation_cell_base_with_circumcenter_3.h"
          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.

Steps To ReproduceEdit etc/config.sh/CGAL to

boost_version=boost-system
#cgal_version=cgal-system
#cgal_version=CGAL-4.10
cgal_version=CGAL-5.0.2

then

> foam; ./Allwmake -update or
> foam; ./Allwmake
TagsNo tags attached.

Relationships

related to 0003500 resolvedwill Missing touches on the update to the new CGAL and Boost header-only method 

Activities

will

2020-05-19 08:35

manager   ~0011354

It works locally for me. The include path in the compile command seems correct.

    -I/home/cfd/OpenFOAM/ThirdParty-dev/CGAL-5.0.2/include

Does the header file referenced in the error message exist in that location?

    /home/cfd/OpenFOAM/ThirdParty-dev/CGAL-5.0.2/include/CGAL/Delaunay_triangulation_cell_base_with_circumcenter_3.h

Does running the Allwclean in the foamyMesh directory beforehand help?

gskillas

2020-05-19 08:55

reporter   ~0011355

Hello Will

the include directory does not exist. The path to the file is ./Triangulation_3/include/CGAL/Delaunay_triangulation_cell_base_with_circumcenter_3.h

Allwclean (obviously) does not help

Best,

George

gskillas

2020-05-19 08:56

reporter   ~0011356

Full path: /home/cfd/OpenFOAM/ThirdParty-dev/CGAL-5.0.2/Triangulation_3/include/CGAL/Delaunay_triangulation_cell_base_with_circumcenter_3.h

will

2020-05-19 10:28

manager   ~0011357

You need to unpack the sources into your ThirdParty-dev if you're not using cgal-system. Unpack this:

   https://github.com/CGAL/cgal/releases/download/releases%2FCGAL-5.0.2/CGAL-5.0.2.tar.xz

Here:

    /home/cfd/OpenFOAM/ThirdParty-dev/CGAL-5.0.2

gskillas

2020-05-19 23:00

reporter   ~0011359

Hello Will

the sources are there:

~/OpenFOAM/ThirdParty-dev > ls cgal-releases-CGAL-5.0.2.tar.gz CGAL-5.0.2/
cgal-releases-CGAL-5.0.2.tar.gz

CGAL-5.0.2/:
AABB_tree CGAL_Core Envelope_2 Interval_support Nef_2 Polygon_mesh_processing Set_movable_separability_2 Surface_mesh_simplification
Advancing_front_surface_reconstruction CGAL_ImageIO Envelope_3 Inventor Nef_3 Polyhedron Shape_detection Surface_mesh_skeletonization
Algebraic_foundations CGAL_ipelets Filtered_kernel Jet_fitting_3 Nef_S2 Polyhedron_IO Skin_surface_3 Surface_sweep_2
Algebraic_kernel_d Circular_kernel_2 Generalized_map Kernel_23 NewKernel_d Polyline_simplification_2 Snap_rounding_2 TDS_2
Algebraic_kernel_for_circles Circular_kernel_3 Generator Kernel_d Number_types Polynomial Solver_interface TDS_3
Algebraic_kernel_for_spheres Circulator Geomview LEDA OpenNL Polytope_distance_d Spatial_searching Testsuite
Alpha_shapes_2 Classification GraphicsView LICENSE.md Optimal_transportation_reconstruction_2 Principal_component_analysis Spatial_sorting Three
Alpha_shapes_3 CMakeLists.txt HalfedgeDS Linear_cell_complex Optimisation_basic Principal_component_analysis_LGPL STL_Extension Triangulation
Apollonius_graph_2 cmake_uninstall.cmake.in Hash_map MacOSX Partition_2 Profiling_tools Straight_skeleton_2 Triangulation_2
Arithmetic_kernel Combinatorial_map Heat_method_3 Maintenance Periodic_2_triangulation_2 Property_map Stream_lines_2 Triangulation_3
Arrangement_on_surface_2 Cone_spanners_2 Homogeneous_kernel Matrix_search Periodic_3_mesh_3 QP_solver Stream_support Union_find
Barycentric_coordinates_2 Convex_decomposition_3 Hyperbolic_triangulation_2 Mesh_2 Periodic_3_triangulation_3 Random_numbers Subdivision_method_3 Visibility_2
BGL Convex_hull_2 Inscribed_areas Mesh_3 Periodic_4_hyperbolic_triangulation_2 README.md Surface_mesh Voronoi_diagram_2
Boolean_set_operations_2 Convex_hull_3 Installation Mesher_level Point_set_2 Ridges_3 Surface_mesh_approximation wininst
Bounding_volumes Convex_hull_d INSTALL.md Minkowski_sum_2 Point_set_3 Scale_space_reconstruction_3 Surface_mesh_deformation
Box_intersection_d copyright Interpolation Minkowski_sum_3 Point_set_processing_3 Scripts Surface_mesher
Cartesian_kernel Distance_2 Intersections_2 Miscellany Poisson_surface_reconstruction_3 SearchStructures Surface_mesh_parameterization
ccpp.yml Distance_3 Intersections_3 Modifier Polygon Segment_Delaunay_graph_2 Surface_mesh_segmentation
CGALConfig.cmake Documentation Interval_skip_list Modular_arithmetic Polygonal_surface_reconstruction Segment_Delaunay_graph_Linf_2 Surface_mesh_shortest_path
~/OpenFOAM/ThirdParty-dev >

It seems that the include directory is under Installation:

~/OpenFOAM/ThirdParty-dev/CGAL-5.0.2 > dir Installation/
total 352
-rw-r--r-- 1 cfd users 1724 Feb 14 14:53 AUTHORS
drwxr-xr-x 4 cfd users 59 Feb 14 14:53 auxiliary
-rw-r--r-- 1 cfd users 155 Feb 14 14:53 CGALConfig.cmake
-rw-r--r-- 1 cfd users 219104 Feb 14 14:53 CHANGES.md
drwxr-xr-x 3 cfd users 20 Feb 14 14:53 cmake
-rw-r--r-- 1 cfd users 54737 Feb 14 14:53 CMakeLists.txt
drwxr-xr-x 2 cfd users 27 Feb 14 14:53 demo
drwxr-xr-x 4 cfd users 79 Feb 14 14:53 doc_html
drwxr-xr-x 2 cfd users 27 Feb 14 14:53 examples
drwxr-xr-x 3 cfd users 17 Feb 14 14:53 include
-rw-r--r-- 1 cfd users 462 Feb 14 14:53 INSTALL.md
drwxr-xr-x 3 cfd users 18 Feb 14 14:53 lib
-rw-r--r-- 1 cfd users 2146 Feb 14 14:53 LICENSE
-rw-r--r-- 1 cfd users 1338 Feb 14 14:53 LICENSE.BSL
-rw-r--r-- 1 cfd users 340 Feb 14 14:53 LICENSE.COMMERCIAL
-rw-r--r-- 1 cfd users 1168 Feb 14 14:53 LICENSE.FREE_USE
-rw-r--r-- 1 cfd users 35147 Feb 14 14:53 LICENSE.GPL
-rw-r--r-- 1 cfd users 7651 Feb 14 14:53 LICENSE.LGPL
-rw-r--r-- 1 cfd users 1055 Feb 14 14:53 LICENSE.RFL
drwxr-xr-x 3 cfd users 25 Feb 14 14:53 package_info
-rw-r--r-- 1 cfd users 1764 Feb 14 14:53 README
drwxr-xr-x 3 cfd users 68 Feb 14 14:53 src
drwxr-xr-x 3 cfd users 46 Feb 14 14:53 test
~/OpenFOAM/ThirdParty-dev/CGAL-5.0.2 >

gskillas

2020-05-19 23:15

reporter   ~0011360

Hello Will

I think I got it. on https://github.com/CGAL/cgal/releases/tag/releases%2FCGAL-5.0.2 I downloaded the "Source code" (last position on the page), while you are working with CGAL-5.0.2.tar.xz (somewhere in the middle of the page). Up to now with the makeCGAL script it did not make a difference, but the two packages are not entirely identical. Using CGAL-5.0.2.tar.xz resolves the issue.

Best

George

will

2020-05-20 09:29

manager   ~0011361

Ah, ok, I see it now. CGAL's cmake configuration presumably used to deal with the fact that the sources were in a different place and ultimately installed them all to the same place. We're not using that any more, though, so we no longer get that advantage.

I think it's better to insist on the "CGAL-5.0.2.tar.xz" pack rather than also allow the "cgal-releases-CGAL-5.0.2.tar.gz" pack, partly because the latter requires renaming following extraction anyway, but mostly because the former is a tenth of the size. The "cgal-releases-CGAL-5.0.2.tar.gz" pack has all the documentation and examples and test data and such that we don't need.

What would be nice is if the ThirdParty-dev/Allwmake just downloaded it automatically if FOAMY_HEX_MESH is true and CGAL_ARCH_PATH is set (ditto boost). The same could be done for scotch; we could stop having to bundle it. None of this is critical, though. I'll add it to the long list.

No changes necessary then, for now. Closing.

Issue History

Date Modified Username Field Change
2020-05-17 08:50 gskillas New Issue
2020-05-19 08:35 will Note Added: 0011354
2020-05-19 08:55 gskillas Note Added: 0011355
2020-05-19 08:56 gskillas Note Added: 0011356
2020-05-19 10:28 will Note Added: 0011357
2020-05-19 23:00 gskillas Note Added: 0011359
2020-05-19 23:15 gskillas Note Added: 0011360
2020-05-20 09:29 will Assigned To => will
2020-05-20 09:29 will Status new => closed
2020-05-20 09:29 will Resolution open => no change required
2020-05-20 09:29 will Note Added: 0011361
2020-06-01 11:21 wyldckat Relationship added related to 0003500