View Issue Details

IDProjectCategoryView StatusLast Update
0003491OpenFOAMContributionpublic2020-05-08 11:55
ReporterarohnerAssigned Towill 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnixOSUbuntuOS Version20.04
Product Version7 
Fixed in Version7 
Summary0003491: Compilation with some Errors
DescriptionHello All

I couldn't wait for the packaged version of OpenFOAM for ubuntu-20.04. Is there already a certain date, when this package will be available?
Compilation from source generated some errors, which I judge as minor relevant, since everything seems to work as expected. I anyway added the log from the compilation. I would also suggest to update the compilation procedure on openfoam.org. The one found in openfoamwiki.net gives a slightly more detailed step-by-step workflow:

https://openfoamwiki.net/index.php/Installation/Linux/OpenFOAM-7/Ubuntu/18.04

Let me know, whether I can help with further information or contribute anything else.
TagsNo tags attached.

Activities

arohner

2020-05-06 11:32

reporter  

compilation2004_logs.tar.gz (11,643 bytes)

wyldckat

2020-05-06 14:14

updater   ~0011332

From what I can quickly see in the log files, only CGAL is failing to compile, likely due to some detail between the CGAL version that Ubuntu 20.04 brings and the version that OpenFOAM was tested with... either that and/or because of the GCC version.

It also seemed like the readers for ParaView didn't build, either due to CMake version or due to ParaView not having been built yet?

Either way, you can run Allwmake with the -k option so that it ignores errors and proceed building the remaining binaries, e.g.:

   ./Allwmake -j 4 -k > log2.make 2>&1

I'll also try to build it on Ubuntu 20.04 sometime this week... I'm curious and I am still using 16.04...

will

2020-05-08 11:55

manager   ~0011333

Resolved in 7 and dev by the following commits

https://github.com/OpenFOAM/OpenFOAM-7/commit/3bcbaf946ae937ab98c0261764a22451a52bac95
https://github.com/OpenFOAM/OpenFOAM-dev/commit/83bd225910e29b9b952eafe011066d9b79f6cdf7

CGAL (and Boost) is now being used header-only, which requires version 4.9 or above. If that's not available on a system it will need downloading and unpacking into ThirdParty, and the version number in the CGAL setup file changing accordingly. Fortunately, because it's now header-only, that's all you have to do. There's no library to build.

Issue History

Date Modified Username Field Change
2020-05-06 11:32 arohner New Issue
2020-05-06 11:32 arohner File Added: compilation2004_logs.tar.gz
2020-05-06 14:14 wyldckat Note Added: 0011332
2020-05-08 11:55 will Assigned To => will
2020-05-08 11:55 will Status new => resolved
2020-05-08 11:55 will Resolution open => fixed
2020-05-08 11:55 will Fixed in Version => 7
2020-05-08 11:55 will Note Added: 0011333