View Issue Details

IDProjectCategoryView StatusLast Update
0003485OpenFOAMBugpublic2020-04-16 16:51
ReporterTobermoryAssigned Tohenry 
PrioritylowSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version12.10
Product Version7 
Fixed in Versiondev 
Summary0003485: Error in the description of the blended scheme for the omega wall function
DescriptionIn the documentation for the omega wall function (https://cpp.openfoam.org/v7/classFoam_1_1omegaWallFunctionFvPatchScalarField.html), under "Detailed Description", the text states that with the blended scheme, the omega value is calculated from the sqrt of the sum of the squares of the viscous and turbulent (log law) values. Looking at the code in https://cpp.openfoam.org/v7/omegaWallFunctionFvPatchScalarField_8C_source.html, on line 236 you can see:

omega0[celli] += w*(lamFrac*omegaVis + turbFrac*omegaLog);

in other words, it is a simple linear blend, not a root-square blend.
Steps To ReproduceReview the documentation.
Additional InformationI suspect that this is legacy text, since i know that these wall functions have been revisited a few times over the last decade.
TagsNo tags attached.

Activities

henry

2020-04-16 16:51

manager   ~0011295

Resolved in OpenFOAM-dev by commit 46f5de875da3acc9c1bc8a81ef05978581ea1d6b

Issue History

Date Modified Username Field Change
2020-04-16 16:15 Tobermory New Issue
2020-04-16 16:51 henry Assigned To => henry
2020-04-16 16:51 henry Status new => resolved
2020-04-16 16:51 henry Resolution open => fixed
2020-04-16 16:51 henry Fixed in Version => dev
2020-04-16 16:51 henry Note Added: 0011295