View Issue Details

IDProjectCategoryView StatusLast Update
0000347OpenFOAM[All Projects] Bugpublic2018-06-17 21:28
ReporterjherbAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSOtherOS Version(please specify)
Product Version 
Fixed in Versiondev 
Summary0000347: Cannot stitch more than two regions to join using stitchMesh
DescriptionI cannot stitch two (or more) interfaces between different meshes. The second call to stitchMesh results in the error message:
Master or slave face zone contain no faces. Please check your mesh definition.

The problem is also described here:
http://www.cfd-online.com/Forums/openfoam-meshing-utilities/93906-more-than-two-regions-join-using-stitchmesh-partial-perfect-option.html

But I can reproduce it with or without the -partial option
Steps To Reproducemerge meshes with more than two regions (together).

stitch first interface (works)
stitch second interface (fails)
Additional InformationThe link above contains an example
TagsstitchMesh

Activities

wyldckat

2013-10-20 09:01

updater   ~0002567

Greetings,

I was browsing the list of open reports here at the bug tracker and noticed that this one I knew what the problem is. And it still occurs on OpenFOAM 2.2.

Here's a more complete description of the steps necessary to reproduce the error:

1. The example case provided on the thread above is a pipe split in 3 parts and the 3 mesh parts connect perfectly fine with each other.

2. Since "stitchMesh" can only stitch one patch pair at a time, the file "*/polyMesh/meshModifiers" is always created on each execution. The problem is that when it's present for the second run of "stitchMesh", the error shown above appears, because that file is sort-of contaminating the perspective as to what the mesh looks like.

3. If the file "*/polyMesh/meshModifiers" is removed before the subsequent calls to "stitchMesh", it works just fine without any errors.


The way I see it, there are a few possible solutions here:
1. The creation of said file should be an option, or the usage of said file should be an option.

2. The mechanism that uses the "meshModifiers" should be improved to allow multiple similar manipulations of the mesh.

3. To implement a stitchMesh variant that can do multiple stitch operations, such as this one: https://github.com/wyldckat/stitchMeshMultiPatch

Regarding the last one, I haven't made a proposition for a "pull request" to the Unsupported Contributions project, because the repository for 2.2.x is not yet available.

Best regards,
Bruno

wyldckat

2018-06-17 21:28

updater   ~0009789

This issue was fixed back in April 2018, in commit 484c16a5da1896d1141f832aecfbfc0ce251f434 of OpenFOAM-dev.

The solution was to not write the mesh modifiers, therefore 'stitchMesh' would not load those modifiers the next time it is run.

Issue History

Date Modified Username Field Change
2011-11-25 18:08 jherb New Issue
2013-10-20 09:01 wyldckat Note Added: 0002567
2015-08-17 01:21 wyldckat Tag Attached: stitchMesh
2018-06-17 21:28 wyldckat Assigned To => henry
2018-06-17 21:28 wyldckat Status new => resolved
2018-06-17 21:28 wyldckat Resolution open => fixed
2018-06-17 21:28 wyldckat Fixed in Version => dev
2018-06-17 21:28 wyldckat Note Added: 0009789