View Issue Details

IDProjectCategoryView StatusLast Update
0003469OpenFOAMBugpublic2020-03-23 14:11
ReporterAristotelis IordanidisAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformGNU/LinuxOSCentOSOS Version6.8
Product Version7 
Fixed in Versiondev 
Summary0003469: error if faces contains binary faceList
DescriptionCheck the attached example.
In the file:

.../constant/polyMesh/faces

the binary section is written as faceList.

In OpenFOAM v7, when executing a utility, e.g. checkMesh, it crashes with this error:

--> FOAM FATAL IO ERROR:
Expected a ')' while reading binaryBlock, found on line 25 an error

file: /.../2volumes/constant/polyMesh/faces at line 25.

    From function Foam::Istream& Foam::Istream::readEnd(const char*)
    in file db/IOstreams/IOstreams/Istream.C at line 109.

FOAM exiting

In OpenFOAM v6, utilities are able to process this case.
TagsNo tags attached.

Activities

Aristotelis Iordanidis

2020-03-19 10:22

reporter  

2volumes.tar.gz (2,649 bytes)

henry

2020-03-19 10:30

manager   ~0011255

How was the constant/polyMesh/faces file generated?

Can you provide the steps to reproduce including the method to generate the constant/polyMesh/faces file?
Can you reproduce the problem in a tutorial case?

henry

2020-03-19 11:45

manager   ~0011257

It looks like there is a bug in the ANSA OpenFOAM export function, you will need to contact the producers of ANSA about this as their software in not open-source.

If you can reproduce the problem using any of the mesh generation or manipulation tools in OpenFOAM we can take a look at it.

henry

2020-03-19 12:17

manager   ~0011259

Do you support OpenFOAM v7? Is looks like your export module needs updating.

wyldckat

2020-03-19 13:38

updater   ~0011260

I've actually been using ANSA recently and for me the version 20.1.1 of ANSA is exporting the "faces" file as type "faceCompactList", which OpenFOAM 7 has no problems using.

I suspect that in ANSA, the export to v1.5 version compatibility option was used, instead of the v4.0.

henry

2020-03-23 14:11

manager   ~0011274

We are unable to reproduce this problem in OpenFOAM and do not have access to ANSA which is closed-source. It appears the bug is in ANSA rather than OpenFOAM.

Issue History

Date Modified Username Field Change
2020-03-19 10:22 Aristotelis Iordanidis New Issue
2020-03-19 10:22 Aristotelis Iordanidis File Added: 2volumes.tar.gz
2020-03-19 10:30 henry Note Added: 0011255
2020-03-19 11:45 henry Note Added: 0011257
2020-03-19 12:17 henry Note Added: 0011259
2020-03-19 13:38 wyldckat Note Added: 0011260
2020-03-23 14:11 henry Assigned To => henry
2020-03-23 14:11 henry Status new => closed
2020-03-23 14:11 henry Resolution open => unable to reproduce
2020-03-23 14:11 henry Fixed in Version => dev
2020-03-23 14:11 henry Note Added: 0011274