View Issue Details

IDProjectCategoryView StatusLast Update
0003466OpenFOAMBugpublic2020-03-15 10:18
ReporterHeikuna MatataAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformUbuntu 18.04.4 LTS bionicOSOtherOS Version(please specify)
Product Version7 
Fixed in Versiondev 
Summary0003466: Error using rhoCentralFoam's BC maxwellSlipU parallel
DescriptionHello,

I noticed a problem concerning rhoCentralFoam's boundary condition maxwellSlipU. The boundary condition contains 3 vector fields, Uwall, value and refValue. When running a case parallel and reconstructing the case, it can occur, that these vector fields aren't reconstructed as vector fields, but as scalar fields containing numeric limits values. Without parallelization this issue doesn't occur.
The results can be viewed in paraView without errors, but if one wants to simulate further steps from this reconstructed state the following error message occurs:

/*---------------------------------------------------------------------------*\
  ========= |
  \\ / F ield | OpenFOAM: The Open Source CFD Toolbox
   \\ / O peration | Website: https://openfoam.org
    \\ / A nd | Version: 7
     \\/ M anipulation |
\*---------------------------------------------------------------------------*/
Build : 7-1ff648926f77
Exec : rhoCentralFoam
Date : Mar 11 2020
Time : 13:42:33
Host : "ip98linux"
PID : 3327
I/O : uncollated
Case : /home/pleskun/Heiko/CouetteFlow/b_h_2/p10/test2Cores/testCase
nProcs : 1
sigFpe : Enabling floating point exception trapping (FOAM_SIGFPE).
fileModificationChecking : Monitoring run-time modified files using timeStampMaster (fileModificationSkew 10)
allowSystemOperations : Allowing user-supplied system call operations

// * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * //
Create time

Create mesh for time = 1e-06

Reading thermophysical properties

Selecting thermodynamics package
{
    type hePsiThermo;
    mixture pureMixture;
    transport const;
    thermo hConst;
    equationOfState perfectGas;
    specie specie;
    energy sensibleInternalEnergy;
}

Reading field U



--> FOAM FATAL ERROR:
Attempt to cast type N4Foam5token8CompoundINS_4ListIdEEEE to type N4Foam5token8CompoundINS_4ListINS_6VectorIdEEEEEE

    From function To& Foam::dynamicCast(From&) [with To = Foam::token::Compound<Foam::List<Foam::Vector<double> > >; From = Foam::token::compound]
    in file /home/ubuntu/OpenFOAM/OpenFOAM-7/src/OpenFOAM/lnInclude/typeInfo.H at line 93.

FOAM aborting

#0 Foam::error::printStack(Foam::Ostream&) at ??:?
#1 Foam::error::abort() at ??:?
#2 Foam::Istream& Foam::operator>><Foam::Vector<double> >(Foam::Istream&, Foam::List<Foam::Vector<double> >&) in "/opt/openfoam7/platforms/linux64GccDPInt32Opt/bin/rhoCentralFoam"
#3 Foam::Field<Foam::Vector<double> >::Field(Foam::word const&, Foam::dictionary const&, int) in "/opt/openfoam7/platforms/linux64GccDPInt32Opt/bin/rhoCentralFoam"
#4 Foam::maxwellSlipUFvPatchVectorField::maxwellSlipUFvPatchVectorField(Foam::fvPatch const&, Foam::DimensionedField<Foam::Vector<double>, Foam::volMesh> const&, Foam::dictionary const&) at ??:?
#5 Foam::fvPatchField<Foam::Vector<double> >::adddictionaryConstructorToTable<Foam::maxwellSlipUFvPatchVectorField>::New(Foam::fvPatch const&, Foam::DimensionedField<Foam::Vector<double>, Foam::volMesh> const&, Foam::dictionary const&) at ??:?
#6 Foam::fvPatchField<Foam::Vector<double> >::New(Foam::fvPatch const&, Foam::DimensionedField<Foam::Vector<double>, Foam::volMesh> const&, Foam::dictionary const&) in "/opt/openfoam7/platforms/linux64GccDPInt32Opt/bin/rhoCentralFoam"
#7 Foam::GeometricField<Foam::Vector<double>, Foam::fvPatchField, Foam::volMesh>::Boundary::readField(Foam::DimensionedField<Foam::Vector<double>, Foam::volMesh> const&, Foam::dictionary const&) in "/opt/openfoam7/platforms/linux64GccDPInt32Opt/bin/rhoCentralFoam"
#8 Foam::GeometricField<Foam::Vector<double>, Foam::fvPatchField, Foam::volMesh>::readFields(Foam::dictionary const&) in "/opt/openfoam7/platforms/linux64GccDPInt32Opt/bin/rhoCentralFoam"
#9 Foam::GeometricField<Foam::Vector<double>, Foam::fvPatchField, Foam::volMesh>::readFields() in "/opt/openfoam7/platforms/linux64GccDPInt32Opt/bin/rhoCentralFoam"
#10 Foam::GeometricField<Foam::Vector<double>, Foam::fvPatchField, Foam::volMesh>::GeometricField(Foam::IOobject const&, Foam::fvMesh const&) in "/opt/openfoam7/platforms/linux64GccDPInt32Opt/bin/rhoCentralFoam"
#11 ? in "/opt/openfoam7/platforms/linux64GccDPInt32Opt/bin/rhoCentralFoam"
#12 __libc_start_main in "/lib/x86_64-linux-gnu/libc.so.6"
#13 ? in "/opt/openfoam7/platforms/linux64GccDPInt32Opt/bin/rhoCentralFoam"
Abgebrochen (Speicherabzug geschrieben)

Steps To ReproduceUse the attached test case with following commands

blockMesh
decomposePar
mpirun -np 4 rhoCentralFoam -parallel
reconstructPar

Check the vectorFields Uwall and refValue in boundary upperWall at time step 1e-6 of the U field. These are now described as nonuniform List<scalar> instead of nonuniform List<vector>.
I think it is because processor0 does not contain any part of this boundary.

Change endTime in the controlDict to 2e-6 and rerun the simulation to get the above mentioned error message.
Additional InformationOne can fix it by hand, with the correct values, but this can be a very annoying task especially when you have several million cells and many simulations.

Cheers,
Heiko
TagsNo tags attached.

Activities

Heikuna Matata

2020-03-11 13:17

reporter  

testCase.7z (2,363 bytes)

henry

2020-03-11 23:23

manager   ~0011248

This should be resolved in OpenFOAM-dev by commit 220507b4f5b54220d12054606ac24079f8627975

Heikuna Matata

2020-03-13 08:03

reporter   ~0011249

Thank you very much.

henry

2020-03-15 10:18

manager   ~0011250

Resolved in OpenFOAM-dev by commit 220507b4f5b54220d12054606ac24079f8627975

Issue History

Date Modified Username Field Change
2020-03-11 13:17 Heikuna Matata New Issue
2020-03-11 13:17 Heikuna Matata File Added: testCase.7z
2020-03-11 23:23 henry Note Added: 0011248
2020-03-13 08:03 Heikuna Matata Note Added: 0011249
2020-03-15 10:18 henry Assigned To => henry
2020-03-15 10:18 henry Status new => resolved
2020-03-15 10:18 henry Resolution open => fixed
2020-03-15 10:18 henry Fixed in Version => dev
2020-03-15 10:18 henry Note Added: 0011250