View Issue Details

IDProjectCategoryView StatusLast Update
0003442OpenFOAMBugpublic2020-02-17 16:40
Reportersjohn2Assigned Tohenry 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSOpenSuSEOS Version12.3
Product Version6 
Fixed in Versiondev 
Summary0003442: Unexpected drop at inlet temperatures noticed in reactingTwoPhaseEulerFoam
DescriptionThe problem being simulated is flashing (phase change from liquid to gas) of steam in a convergent-divergent nozzle. Pure liquid enters the nozzle at the inlet and the phases change occurs downstream of the throat due the pressure dropping below the saturation value. The solver being used is the reactingTwoPhaseEulerFoam with the interfaceCompositionPhaseChangeTwoPhaseSystem phase system. The interface composition system being used is the Saturated type with both the constant and the antonie type are tested. A single species exists in each of the phase.

PROBLEM FACED:
The phase change is triggered only with specification of a small value of the initial volume fraction of the gas phase (1e-12).
Unexplained temperature drop is developed and convected near the first control volume near the inlet boundary. This leads to low temperatures being transported throughout the nozzle thereby leading to drop in saturation pressures and temperatures.
Steps To ReproduceAll required files can be downloaded from the links given in pdf file attached
TagsNo tags attached.

Activities

sjohn2

2020-02-06 05:09

reporter  

REPORT.pdf (265,224 bytes)

henry

2020-02-06 08:27

manager   ~0011127

reactingTwoPhaseEulerFoam is under active development and there have been many improvements in OpenFOAM-7 and OpenFOAM-dev. Please re-run your case in the latest OpenFOAM-dev.

sjohn2

2020-02-07 07:09

reporter   ~0011142

I have tested this case on OpenFoam version 7 and have found the same issues. Please find attached the results file>
I will test the case on OpenFOam-dev within couple of weeks and report.

https://www.dropbox.com/s/noo2q6vvevc86d5/CD_NOZ_3D_rtpef_BNL_291_lam_cse8_TP_oldcase_of7.tar.xz?dl=1

sjohn2

2020-02-16 02:05

reporter   ~0011186

I have tested this case with latest -dev version of Openfoam and found that the problem still persists.
Please find attached the files
 https://www.dropbox.com/s/19oahlx7688gb7y/CD_NOZ_3D_rtpef_BNL_291_lam_cse8_TP_oldcase_of7_dev.zip?dl=1

henry

2020-02-17 10:27

manager   ~0011190

The case has a few setup problems and takes a long time to run, can you provide an 2D axisymmetric version for testing?

henry

2020-02-17 14:09

manager   ~0011191

The temperature issue is caused by an accumulation of error from the pressure work term in the internal energy equation from the very small but non-zero continuity error.
To avoid this kind of error accumulation in pure incompressible phases there is an optional pressureWorkAlphaLimit control which you can set and it resolves the problem.
I have also improved the pressure work term formulation to include a continuity error compensation term:

commit 17afa7d79b09f7d2dbf71f55925c041e0f2bd32f (HEAD -> master, origin/master, origin/HEAD)
Author: Henry Weller <http://openfoam.org>
Date: Mon Feb 17 14:04:45 2020 +0000

    reactingEulerFoam::AnisothermalPhaseModel: Added a continuity error compensation term to the internal energy pressure work
    
    Reduced the accumulation of error for incompressible and low compressibility
    cases.

sjohn2

2020-02-17 14:46

reporter   ~0011192

Thank you Henry for the changes. I will test it when the repository package files are updated and the software is upgraded.
Can I also please request you to upload the new case with the corrected setup problems that I have missed. This will help verification and my studies at the university.

henry

2020-02-17 14:56

manager   ~0011193

It would make more sense to work on an axisymmetric case; I don't see the need to run this case 3D unless you want to run it LES.

The issue with the phase change occurring only when there is at least some gas is that the current phase-change modelling is not designed for spontaneous flashing; it occurs at the interface between the phases so the interface need s to be present. Funding would be required to develop reactingEulerFoam for flashing calculations.

henry

2020-02-17 16:40

manager   ~0011195

Resolved by commit 17afa7d79b09f7d2dbf71f55925c041e0f2bd32f

Issue History

Date Modified Username Field Change
2020-02-06 05:09 sjohn2 New Issue
2020-02-06 05:09 sjohn2 File Added: REPORT.pdf
2020-02-06 08:27 henry Note Added: 0011127
2020-02-07 07:09 sjohn2 Note Added: 0011142
2020-02-16 02:05 sjohn2 Note Added: 0011186
2020-02-17 10:27 henry Note Added: 0011190
2020-02-17 14:09 henry Note Added: 0011191
2020-02-17 14:46 sjohn2 Note Added: 0011192
2020-02-17 14:56 henry Note Added: 0011193
2020-02-17 16:40 henry Assigned To => henry
2020-02-17 16:40 henry Status new => resolved
2020-02-17 16:40 henry Resolution open => fixed
2020-02-17 16:40 henry Fixed in Version => dev
2020-02-17 16:40 henry Note Added: 0011195