View Issue Details

IDProjectCategoryView StatusLast Update
0003428OpenFOAMBugpublic2020-01-13 19:56
ReporterfedeAssigned Tohenry 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSDebianOS Version9
Product Versiondev 
Fixed in Versiondev 
Summary0003428: missing orderType definition in constructor - coupledPolyPatch.C
DescriptionIn coupledPolyPatch.C, definition of the protected variable ordering_ is missing in some constructors. This causes crashes in the code anytime utilities (decomposePar for example) operate on a mesh where cyclicAMI constraints are present.

Please find attached the corrected version of coupledPolyPatch.C, that fixes the issue.

Wish this helps.
Steps To ReproducePlease run the Allrun script in the tutorial case:


           $FOAM_TUTORIALS/incompressible/simpleFoam/pipeCyclic
TagsNo tags attached.

Activities

fede

2020-01-13 18:17

reporter  

coupledPolyPatch.C (9,349 bytes)

henry

2020-01-13 18:38

manager   ~0011056

I just ran the $FOAM_TUTORIALS/incompressible/simpleFoam/pipeCyclic and it runs fine so I am not able to reproduce the problem. Nevertheless I will check the patch you have provided.

henry

2020-01-13 19:56

manager   ~0011057

Resolved by commit 2771c1f85c267e9925c2796b52b3ae010fae6179

Issue History

Date Modified Username Field Change
2020-01-13 18:17 fede New Issue
2020-01-13 18:17 fede File Added: coupledPolyPatch.C
2020-01-13 18:38 henry Note Added: 0011056
2020-01-13 19:56 henry Assigned To => henry
2020-01-13 19:56 henry Status new => resolved
2020-01-13 19:56 henry Resolution open => fixed
2020-01-13 19:56 henry Fixed in Version => dev
2020-01-13 19:56 henry Note Added: 0011057