View Issue Details

IDProjectCategoryView StatusLast Update
0003424OpenFOAMBugpublic2020-01-09 09:03
ReportertungliAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformGNU/LinuxOSManjaro Linux x86_64OS Version4.19.88-1
Product Versiondev 
Fixed in Version 
Summary0003424: Dynamic mesh refinement does not refine axis for axisymmetric setup
DescriptionI set up a simple solver and a case with a dynamic mesh refinement using a wedge domain.
The refinement criterion is the distance from the axis (solver only updates the mesh, does not solve any PDE).

My problem is that the mesh refinement does not refine the axis line. The refinement of cells progresses from level 1 to whatever the maximum level starting from the axis (see the picture in included files).

Is this behavior intended/desired? If so, how can this be side-stepped if the critical region (where the largest refinement is needed) is around the axis?
Steps To ReproduceI used OpenFOAM-dev, last commit 22bba48722738e54f215909839aa536f69e8b1eb

Solver and case files are included. `tar -xvzf <file>` to unzip.

`wmake` to compile the solver.

`blockMesh` and `wedgeRef` for case.
TagsNo tags attached.

Activities

tungli

2020-01-08 08:52

reporter  

wedgeRef.tar.gz (1,273 bytes)
wedgeRef_case.tar.gz (1,867 bytes)

henry

2020-01-09 09:03

manager   ~0011050

dynamicRefineFvMesh is not appropriate for wedge cases as it splits hex cells in all 3 directions and does not support the triangular prisms on the pole of a wedge nor the hex cells of a wedge which it also splits in the plane of the wedge causing it two become a 3D mesh.

Issue History

Date Modified Username Field Change
2020-01-08 08:52 tungli New Issue
2020-01-08 08:52 tungli File Added: wedgeRef.tar.gz
2020-01-08 08:52 tungli File Added: wedgeRef_case.tar.gz
2020-01-08 08:52 tungli File Added: 2020-01-07-160320_946x735_scrot.png
2020-01-09 09:03 henry Assigned To => henry
2020-01-09 09:03 henry Status new => closed
2020-01-09 09:03 henry Resolution open => no change required
2020-01-09 09:03 henry Note Added: 0011050