View Issue Details

IDProjectCategoryView StatusLast Update
0003412OpenFOAMBugpublic2019-12-24 11:35
ReporterpmsagdeoAssigned Towyldckat 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformINTELOSUbuntuOS Version18.04 LTS
Product Version7 
Fixed in Version7 
Summary0003412: Version mismatch in simpllefoam
DescriptionInstalled OpenFoam7. The first test after installation shows OpneFoam 4 as the installed version. Please confirm or fix. Thank you.

Pradip Sagdeo
Steps To Reproduce1. Perform fresh install of OpenFoam, making sure no previous version exists on the computer.
2. Install Paraview.
3. Follow directions to complete user configuration.
4. Test installation by running simplefoam -help.

The output screen is attached.
TagsNo tags attached.

Activities

pmsagdeo

2019-12-16 16:22

reporter  

OFVersionMismatch121619.jpg (764,957 bytes)

henry

2019-12-16 16:44

manager   ~0010980

I am unable to reproduce:

simpleFoam -help

Usage: simpleFoam [OPTIONS]
options:
  -case <dir> specify alternate case directory, default is the cwd
  -fileHandler <handler>
                    override the fileHandler
  -hostRoots <(((host1 dir1) .. (hostN dirN))>
                    slave root directories (per host) for distributed running
  -libs <(lib1 .. libN)>
                    pre-load libraries
  -listFunctionObjects
                    List functionObjects
  -listFvOptions List fvOptions
  -listRegisteredSwitches
                    List switches registered for run-time modification
  -listScalarBCs List scalar field boundary conditions (fvPatchField<scalar>)
  -listSwitches List switches declared in libraries but not set in
                    etc/controlDict
  -listTurbulenceModels
                    List turbulenceModels
  -listUnsetSwitches
                    List switches declared in libraries but not set in
                    etc/controlDict
  -listVectorBCs List vector field boundary conditions (fvPatchField<vector>)
  -noFunctionObjects
                    do not execute functionObjects
  -parallel run in parallel
  -postProcess Execute functionObjects only
  -roots <(dir1 .. dirN)>
                    slave root directories for distributed running
  -srcDoc display source code in browser
  -doc display application documentation in browser
  -help print the usage

Using: OpenFOAM-7 (see https://openfoam.org)
Build: 7-3121f5329b52

wyldckat

2019-12-16 16:50

updater   ~0010981

@pmsagdeo: Please run the following commands:

   export | grep -i foam

   which simpleFoam

These will tell us where the settings and installation details are coming from.

If by any chance you have gotten "simpleFoam" at "/usr/bin", then that means that you might have installed a package named "openfoam" by mistake/accident.

pmsagdeo

2019-12-16 19:05

reporter   ~0010982

Attaching the results of the above two commands. No previous instance of OpenFoam existed on the computer. It was a new installation of Ubuntu 18.04 LTS two days ago.
The corrected output from which simpleFoam is below:

pradip@pms-ubuntu-desktop:~$ which simpleFoam
/opt/openfoam7/platforms/linux64GccDPInt32Opt/bin/simpleFoam

OpenFoamInstallation121619 (2,610 bytes)
pradip@pms-ubuntu-desktop:~$ export | grep -i foam
declare -x FOAM_APP="/opt/openfoam7/applications"
declare -x FOAM_APPBIN="/opt/openfoam7/platforms/linux64GccDPInt32Opt/bin"
declare -x FOAM_ETC="/opt/openfoam7/etc"
declare -x FOAM_EXT_LIBBIN="/opt/ThirdParty-7/platforms/linux64GccDPInt32/lib"
declare -x FOAM_INST_DIR="/opt"
declare -x FOAM_JOB_DIR="/opt/jobControl"
declare -x FOAM_LIBBIN="/opt/openfoam7/platforms/linux64GccDPInt32Opt/lib"
declare -x FOAM_MPI="openmpi-system"
declare -x FOAM_RUN="/home/pradip/OpenFOAM/pradip-7/run"
declare -x FOAM_SETTINGS=""
declare -x FOAM_SIGFPE=""
declare -x FOAM_SITE_APPBIN="/opt/site/7/platforms/linux64GccDPInt32Opt/bin"
declare -x FOAM_SITE_LIBBIN="/opt/site/7/platforms/linux64GccDPInt32Opt/lib"
declare -x FOAM_SOLVERS="/opt/openfoam7/applications/solvers"
declare -x FOAM_SRC="/opt/openfoam7/src"
declare -x FOAM_TUTORIALS="/opt/openfoam7/tutorials"
declare -x FOAM_USER_APPBIN="/home/pradip/OpenFOAM/pradip-7/platforms/linux64GccDPInt32Opt/bin"
declare -x FOAM_USER_LIBBIN="/home/pradip/OpenFOAM/pradip-7/platforms/linux64GccDPInt32Opt/lib"
declare -x FOAM_UTILITIES="/opt/openfoam7/applications/utilities"
declare -x LD_LIBRARY_PATH="/opt/ThirdParty-7/platforms/linux64Gcc/gperftools-svn/lib:/opt/paraviewopenfoam56/lib/paraview-5.6:/opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/openmpi-system:/opt/ThirdParty-7/platforms/linux64GccDPInt32/lib/openmpi-system:/usr/lib/x86_64-linux-gnu/openmpi/lib:/home/pradip/OpenFOAM/pradip-7/platforms/linux64GccDPInt32Opt/lib:/opt/site/7/platforms/linux64GccDPInt32Opt/lib:/opt/openfoam7/platforms/linux64GccDPInt32Opt/lib:/opt/ThirdParty-7/platforms/linux64GccDPInt32/lib:/opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/dummy"
declare -x PATH="/opt/ThirdParty-7/platforms/linux64Gcc/gperftools-svn/bin:/opt/paraviewopenfoam56/bin:/home/pradip/OpenFOAM/pradip-7/platforms/linux64GccDPInt32Opt/bin:/opt/site/7/platforms/linux64GccDPInt32Opt/bin:/opt/openfoam7/platforms/linux64GccDPInt32Opt/bin:/opt/openfoam7/bin:/opt/openfoam7/wmake:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin"
declare -x PV_PLUGIN_PATH="/opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/paraview-5.6"
declare -x ParaView_DIR="/opt/paraviewopenfoam56"
declare -x ParaView_INCLUDE_DIR="/opt/paraviewopenfoam56/include/paraview-5.6"
declare -x WM_DIR="/opt/openfoam7/wmake"
declare -x WM_PROJECT="OpenFOAM"
declare -x WM_PROJECT_DIR="/opt/openfoam7"
declare -x WM_PROJECT_USER_DIR="/home/pradip/OpenFOAM/pradip-7"
pradip@pms-ubuntu-desktop:~$ which simplefoam
pradip@pms-ubuntu-desktop:~$ 

will

2019-12-17 09:03

manager   ~0010983

Last edited: 2019-12-17 09:04

View 2 revisions

I have tested the install procedure here https://openfoam.org/download/7-ubuntu on a docker instance running Ubuntu 18.04, and I am unable to reproduce the issue. I get the same output as Henry.

wyldckat

2019-12-17 10:57

updater   ~0010984

@pmsagdeo Please run the following commands:

    ldd $(which simpleFoam)

    ls -l $FOAM_LIBBIN/libOpenFOAM.so

    cat /etc/lsb-release

This is to try and see the origin of the problem, because even though it's a clean installation, it's clear that something got mixed up somewhere... the problem is where exactly did the mix up happen.

pmsagdeo

2019-12-17 13:24

reporter   ~0010985

Ran the above commands. Attaching the output. Thanks.

OpenFoamInstallation121719 (4,720 bytes)
pradip@pms-ubuntu-desktop:~$ ldd $(which simpleFoam)
	linux-vdso.so.1 (0x00007ffd0ddaf000)
	libturbulenceModels.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libturbulenceModels.so (0x00007ff64a6cd000)
	libincompressibleTurbulenceModels.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libincompressibleTurbulenceModels.so (0x00007ff64a218000)
	libincompressibleTransportModels.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libincompressibleTransportModels.so (0x00007ff649f78000)
	libfiniteVolume.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libfiniteVolume.so (0x00007ff648140000)
	libmeshTools.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libmeshTools.so (0x00007ff647a62000)
	libfvOptions.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libfvOptions.so (0x00007ff6475e9000)
	libsampling.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libsampling.so (0x00007ff64706b000)
	libOpenFOAM.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libOpenFOAM.so (0x00007ff646497000)
	libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007ff646293000)
	libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007ff645f0a000)
	libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007ff645b6c000)
	libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007ff645954000)
	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007ff645563000)
	libPstream.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/openmpi-system/libPstream.so (0x00007ff645353000)
	libtwoPhaseMixture.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libtwoPhaseMixture.so (0x00007ff645132000)
	libtriSurface.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libtriSurface.so (0x00007ff644e90000)
	libsurfMesh.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libsurfMesh.so (0x00007ff644b82000)
	libfileFormats.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libfileFormats.so (0x00007ff6448ec000)
	libcompressibleTurbulenceModels.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libcompressibleTurbulenceModels.so (0x00007ff644449000)
	libfluidThermophysicalModels.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libfluidThermophysicalModels.so (0x00007ff643e85000)
	libsolidThermo.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libsolidThermo.so (0x00007ff643b9e000)
	liblagrangian.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/liblagrangian.so (0x00007ff643971000)
	libdynamicMesh.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libdynamicMesh.so (0x00007ff643214000)
	libconversion.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libconversion.so (0x00007ff642f8e000)
	libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007ff642d71000)
	libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007ff642b52000)
	/lib64/ld-linux-x86-64.so.2 (0x00007ff64ada3000)
	libmpi.so.20 => /usr/lib/x86_64-linux-gnu/libmpi.so.20 (0x00007ff642860000)
	libcompressibleTransportModels.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libcompressibleTransportModels.so (0x00007ff64265c000)
	libsolidSpecie.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libsolidSpecie.so (0x00007ff642431000)
	libspecie.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libspecie.so (0x00007ff641cd8000)
	libthermophysicalProperties.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libthermophysicalProperties.so (0x00007ff6419cb000)
	libreactionThermophysicalModels.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libreactionThermophysicalModels.so (0x00007ff640df9000)
	libextrudeModel.so => /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libextrudeModel.so (0x00007ff640bd8000)
	libopen-rte.so.20 => /usr/lib/x86_64-linux-gnu/libopen-rte.so.20 (0x00007ff640950000)
	libopen-pal.so.20 => /usr/lib/x86_64-linux-gnu/libopen-pal.so.20 (0x00007ff64069e000)
	librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007ff640496000)
	libhwloc.so.5 => /usr/lib/x86_64-linux-gnu/libhwloc.so.5 (0x00007ff640259000)
	libutil.so.1 => /lib/x86_64-linux-gnu/libutil.so.1 (0x00007ff640056000)
	libnuma.so.1 => /usr/lib/x86_64-linux-gnu/libnuma.so.1 (0x00007ff63fe4b000)
	libltdl.so.7 => /usr/lib/x86_64-linux-gnu/libltdl.so.7 (0x00007ff63fc41000)
pradip@pms-ubuntu-desktop:~$ ls -l $FOAM_LIBBIN/libOpenFOAM.so
-rw-r--r-- 1 root root 12636024 Nov 18 09:58 /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libOpenFOAM.so
pradip@pms-ubuntu-desktop:~$ cat /etc/lsd-release
cat: /etc/lsd-release: No such file or directory
pradip@pms-ubuntu-desktop:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.04
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION="Ubuntu 18.04.3 LTS"
pradip@pms-ubuntu-desktop:~$ 

wyldckat

2019-12-17 13:48

updater   ~0010986

@pmsagdeo So far, all signs point to something being wrong with how "simpleFoam" was first summoned. Please run the following commands:

    /opt/openfoam7/platforms/linux64GccDPInt32Opt/bin/simpleFoam -help

This one should strictly be giving you the expected help output that Henry showed.

If my suspicion is correct, there is an alias command or function being defined by something else... if you run the following commands, it should point out which ones exist:

    alias

    declare -F


If there are no signs of another "simpleFoam", then run:

    ls -l $FOAM_APPBIN/simpleFoam

   md5sum $FOAM_APPBIN/simpleFoam
   md5sum $FOAM_LIBBIN/libOpenFOAM.so

to see if these files are the ones that are intended to be installed.

pmsagdeo

2019-12-17 14:18

reporter   ~0010988

Ran the commands above. Attaching the output. I do not see any other instance of OpenFOAM. Not sure why I received the version mismatch. I will start using the program and will see if I run into any problems. Thank you all for looking into this. I really appreciate it.

OpenFoamInstallation121719_2 (13,057 bytes)
pradip@pms-ubuntu-desktop:~$  /opt/openfoam7/platforms/linux64GccDPInt32Opt/bin/simpleFoam  -help

Usage: simpleFoam [OPTIONS]
options:
  -case <dir>       specify alternate case directory, default is the cwd
  -fileHandler <handler>
                    override the fileHandler
  -hostRoots <(((host1 dir1) .. (hostN dirN))>
                    slave root directories (per host) for distributed running
  -libs <(lib1 .. libN)>
                    pre-load libraries
  -listFunctionObjects
                    List functionObjects
  -listFvOptions    List fvOptions
  -listRegisteredSwitches
                    List switches registered for run-time modification
  -listScalarBCs    List scalar field boundary conditions (fvPatchField<scalar>)
  -listSwitches     List switches declared in libraries but not set in
                    etc/controlDict
  -listTurbulenceModels
                    List turbulenceModels
  -listUnsetSwitches
                    List switches declared in libraries but not set in
                    etc/controlDict
  -listVectorBCs    List vector field boundary conditions (fvPatchField<vector>)
  -noFunctionObjects
                    do not execute functionObjects
  -parallel         run in parallel
  -postProcess      Execute functionObjects only
  -roots <(dir1 .. dirN)>
                    slave root directories for distributed running
  -srcDoc           display source code in browser
  -doc              display application documentation in browser
  -help             print the usage

Using: OpenFOAM-7 (see https://openfoam.org)
Build: 7-ca808c8420bf

pradip@pms-ubuntu-desktop:~$ alias
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'
alias app='cd $FOAM_APP'
alias egrep='egrep --color=auto'
alias fgrep='fgrep --color=auto'
alias foam='cd $WM_PROJECT_DIR'
alias foamSite='cd $WM_PROJECT_INST_DIR/site'
alias grep='grep --color=auto'
alias l='ls -CF'
alias la='ls -A'
alias lib='cd $FOAM_LIBBIN'
alias ll='ls -alF'
alias ls='ls --color=auto'
alias paraview='paraview --mesa'
alias run='cd $FOAM_RUN'
alias sol='cd $FOAM_SOLVERS'
alias src='cd $FOAM_SRC'
alias tut='cd $FOAM_TUTORIALS'
alias util='cd $FOAM_UTILITIES'
alias wm32='wmSet WM_ARCH_OPTION=32'
alias wm64='wmSet WM_ARCH_OPTION=64'
alias wmDP='wmSet WM_PRECISION_OPTION=DP'
alias wmLP='wmSet WM_PRECISION_OPTION=LP'
alias wmSP='wmSet WM_PRECISION_OPTION=SP'
alias wmSchedOff='unset WM_SCHEDULER'
alias wmSchedOn='export WM_SCHEDULER=$WM_PROJECT_DIR/wmake/wmakeScheduler'
alias wmSet='. $WM_PROJECT_DIR/etc/bashrc'
alias wmUnset='. $WM_PROJECT_DIR/etc/config.sh/unset'
pradip@pms-ubuntu-desktop:~$ declare -F
declare -f _DPMDyMFoam_
declare -f _DPMFoam_
declare -f _MPPICDyMFoam_
declare -f _MPPICFoam_
declare -f _PDRFoam_
declare -f _PDRMesh_
declare -f _SRFPimpleFoam_
declare -f _SRFSimpleFoam_
declare -f _XiEngineFoam_
declare -f _XiFoam_
declare -f __expand_tilde_by_ref
declare -f __get_cword_at_cursor_by_ref
declare -f __grub_dir
declare -f __grub_get_last_option
declare -f __grub_get_options_from_help
declare -f __grub_get_options_from_usage
declare -f __grub_list_menuentries
declare -f __grub_list_modules
declare -f __grubcomp
declare -f __load_completion
declare -f __ltrim_colon_completions
declare -f __parse_options
declare -f __reassemble_comp_words_by_ref
declare -f _adiabaticFlameT_
declare -f _adjointShapeOptimizationFoam_
declare -f _allowed_groups
declare -f _allowed_users
declare -f _ansysToFoam_
declare -f _applyBoundaryLayer_
declare -f _apport-bug
declare -f _apport-cli
declare -f _apport-collect
declare -f _apport-unpack
declare -f _apport_parameterless
declare -f _apport_symptoms
declare -f _attachMesh_
declare -f _autoPatch_
declare -f _autoRefineMesh_
declare -f _available_interfaces
declare -f _blockMesh_
declare -f _boundaryFoam_
declare -f _boxTurb_
declare -f _buoyantPimpleFoam_
declare -f _buoyantSimpleFoam_
declare -f _cavitatingDyMFoam_
declare -f _cavitatingFoam_
declare -f _cd
declare -f _cd_devices
declare -f _cfx4ToFoam_
declare -f _changeDictionary_
declare -f _checkMesh_
declare -f _chemFoam_
declare -f _chemkinToFoam_
declare -f _chtMultiRegionFoam_
declare -f _coalChemistryFoam_
declare -f _coldEngineFoam_
declare -f _collapseEdges_
declare -f _combinePatchFaces_
declare -f _command
declare -f _command_offset
declare -f _complete_as_root
declare -f _completion_loader
declare -f _compressibleInterDyMFoam_
declare -f _compressibleInterFilmFoam_
declare -f _compressibleInterFoam_
declare -f _compressibleMultiphaseInterFoam_
declare -f _configured_interfaces
declare -f _count_args
declare -f _createBaffles_
declare -f _createExternalCoupledPatchGeometry_
declare -f _createPatch_
declare -f _datToFoam_
declare -f _decomposePar_
declare -f _deformedGeom_
declare -f _dnsFoam_
declare -f _driftFluxFoam_
declare -f _dsmcFoam_
declare -f _dsmcInitialise_
declare -f _dvd_devices
declare -f _electrostaticFoam_
declare -f _engineCompRatio_
declare -f _engineFoam_
declare -f _engineSwirl_
declare -f _equilibriumCO_
declare -f _equilibriumFlameT_
declare -f _expand
declare -f _extrude2DMesh_
declare -f _extrudeMesh_
declare -f _extrudeToRegionMesh_
declare -f _faceAgglomerate_
declare -f _filedir
declare -f _filedir_xspec
declare -f _financialFoam_
declare -f _fireFoam_
declare -f _flattenMesh_
declare -f _fluent3DMeshToFoam_
declare -f _fluentMeshToFoam_
declare -f _foamCleanPath_
declare -f _foamCleanPolyMesh_
declare -f _foamCleanTutorials_
declare -f _foamCloneCase_
declare -f _foamCreateVideo_
declare -f _foamDataToFluent_
declare -f _foamDictionary_
declare -f _foamEtcFile_
declare -f _foamExec_
declare -f _foamFormatConvert_
declare -f _foamGet_
declare -f _foamInfo_
declare -f _foamJob_
declare -f _foamListTimes_
declare -f _foamLog_
declare -f _foamMeshToFluent_
declare -f _foamMonitor_
declare -f _foamNewApp_
declare -f _foamNewBC_
declare -f _foamNewFunctionObject_
declare -f _foamNew_
declare -f _foamRunTutorials_
declare -f _foamSearch_
declare -f _foamSequenceVTKFiles_
declare -f _foamSetupCHT_
declare -f _foamTags_
declare -f _foamToEnsightParts_
declare -f _foamToEnsight_
declare -f _foamToGMV_
declare -f _foamToStarMesh_
declare -f _foamToSurface_
declare -f _foamToTetDualMesh_
declare -f _foamToVTK_
declare -f _foamUpdateCaseFileHeader_
declare -f _foamUpgradeCyclics_
declare -f _foamyHexMesh_
declare -f _foamyQuadMesh_
declare -f _fstypes
declare -f _gambitToFoam_
declare -f _get_comp_words_by_ref
declare -f _get_cword
declare -f _get_first_arg
declare -f _get_pword
declare -f _gids
declare -f _gmshToFoam_
declare -f _grub_editenv
declare -f _grub_install
declare -f _grub_mkconfig
declare -f _grub_mkfont
declare -f _grub_mkimage
declare -f _grub_mkpasswd_pbkdf2
declare -f _grub_mkrescue
declare -f _grub_probe
declare -f _grub_script_check
declare -f _grub_set_entry
declare -f _grub_setup
declare -f _have
declare -f _icoFoam_
declare -f _icoUncoupledKinematicParcelDyMFoam_
declare -f _icoUncoupledKinematicParcelFoam_
declare -f _ideasUnvToFoam_
declare -f _included_ssh_config_files
declare -f _init_completion
declare -f _insideCells_
declare -f _installed_modules
declare -f _interFoam_
declare -f _interMixingFoam_
declare -f _interPhaseChangeDyMFoam_
declare -f _interPhaseChangeFoam_
declare -f _ip_addresses
declare -f _kernel_versions
declare -f _kivaToFoam_
declare -f _known_hosts
declare -f _known_hosts_real
declare -f _laplacianFoam_
declare -f _longopt
declare -f _mac_addresses
declare -f _magneticFoam_
declare -f _mapFieldsPar_
declare -f _mapFields_
declare -f _mdEquilibrationFoam_
declare -f _mdFoam_
declare -f _mdInitialise_
declare -f _mergeMeshes_
declare -f _mergeOrSplitBaffles_
declare -f _mergedDyM_
declare -f _mhdFoam_
declare -f _minimal
declare -f _mirrorMesh_
declare -f _mixtureAdiabaticFlameT_
declare -f _modifyMesh_
declare -f _modules
declare -f _moveDynamicMesh_
declare -f _moveEngineMesh_
declare -f _moveMesh_
declare -f _mpirunDebug_
declare -f _mshToFoam_
declare -f _multiphaseEulerFoam_
declare -f _multiphaseInterFoam_
declare -f _ncpus
declare -f _netgenNeutralToFoam_
declare -f _noise_
declare -f _nonNewtonianIcoFoam_
declare -f _objToVTK_
declare -f _orientFaceZone_
declare -f _paraFoam_
declare -f _parse_help
declare -f _parse_usage
declare -f _particleTracks_
declare -f _patchSummary_
declare -f _pci_ids
declare -f _pdfPlot_
declare -f _pgids
declare -f _pids
declare -f _pimpleDyMFoam_
declare -f _pimpleFoam_
declare -f _pisoFoam_
declare -f _plot3dToFoam_
declare -f _pnames
declare -f _polyDualMesh_
declare -f _porousSimpleFoam_
declare -f _postChannel_
declare -f _postProcess_
declare -f _potentialFoam_
declare -f _potentialFreeSurfaceDyMFoam_
declare -f _potentialFreeSurfaceFoam_
declare -f _quote_readline_by_ref
declare -f _reactingFoam_
declare -f _reactingMultiphaseEulerFoam_
declare -f _reactingParcelFoam_
declare -f _reactingTwoPhaseEulerFoam_
declare -f _realcommand
declare -f _reconstructParMesh_
declare -f _reconstructPar_
declare -f _redistributePar_
declare -f _refineHexMesh_
declare -f _refineMesh_
declare -f _refineWallLayer_
declare -f _refinementLevel_
declare -f _removeFaces_
declare -f _renumberMesh_
declare -f _rhoCentralDyMFoam_
declare -f _rhoCentralFoam_
declare -f _rhoPimpleFoam_
declare -f _rhoPorousSimpleFoam_
declare -f _rhoReactingBuoyantFoam_
declare -f _rhoReactingFoam_
declare -f _rhoSimpleFoam_
declare -f _rl_enabled
declare -f _root_command
declare -f _rotateMesh_
declare -f _sammToFoam_
declare -f _scalarTransportFoam_
declare -f _selectCells_
declare -f _service
declare -f _services
declare -f _setFields_
declare -f _setSet_
declare -f _setWaves_
declare -f _setsToZones_
declare -f _shallowWaterFoam_
declare -f _shells
declare -f _signals
declare -f _simpleFoam_
declare -f _simpleReactingParcelFoam_
declare -f _singleCellMesh_
declare -f _smapToFoam_
declare -f _snappyHexMesh_
declare -f _solidDisplacementFoam_
declare -f _solidEquilibriumDisplacementFoam_
declare -f _sonicFoam_
declare -f _sonicLiquidFoam_
declare -f _splitCells_
declare -f _splitMeshRegions_
declare -f _splitMesh_
declare -f _split_longopt
declare -f _sprayDyMFoam_
declare -f _sprayFoam_
declare -f _star3ToFoam_
declare -f _star4ToFoam_
declare -f _steadyParticleTracks_
declare -f _stitchMesh_
declare -f _subsetMesh_
declare -f _surfaceAdd_
declare -f _surfaceAutoPatch_
declare -f _surfaceBooleanFeatures_
declare -f _surfaceCheck_
declare -f _surfaceClean_
declare -f _surfaceCoarsen_
declare -f _surfaceConvert_
declare -f _surfaceFeatureConvert_
declare -f _surfaceFeatureExtract_
declare -f _surfaceFeatures_
declare -f _surfaceFind_
declare -f _surfaceHookUp_
declare -f _surfaceInertia_
declare -f _surfaceLambdaMuSmooth_
declare -f _surfaceMeshConvertTesting_
declare -f _surfaceMeshConvert_
declare -f _surfaceMeshExport_
declare -f _surfaceMeshImport_
declare -f _surfaceMeshInfo_
declare -f _surfaceMeshTriangulate_
declare -f _surfaceOrient_
declare -f _surfacePointMerge_
declare -f _surfaceRedistributePar_
declare -f _surfaceRefineRedGreen_
declare -f _surfaceSplitByPatch_
declare -f _surfaceSplitByTopology_
declare -f _surfaceSplitNonManifolds_
declare -f _surfaceSubset_
declare -f _surfaceToPatch_
declare -f _surfaceTransformPoints_
declare -f _sysvdirs
declare -f _temporalInterpolate_
declare -f _terms
declare -f _tetgenToFoam_
declare -f _thermoFoam_
declare -f _tilde
declare -f _topoSet_
declare -f _transformPoints_
declare -f _twoLiquidMixingFoam_
declare -f _twoPhaseEulerFoam_
declare -f _uids
declare -f _uncoupledKinematicParcelDyMFoam_
declare -f _uncoupledKinematicParcelFoam_
declare -f _upvar
declare -f _upvars
declare -f _usb_ids
declare -f _user_at_host
declare -f _usergroup
declare -f _userland
declare -f _variables
declare -f _viewFactorsGen_
declare -f _vtkUnstructuredToFoam_
declare -f _wallFunctionTable_
declare -f _wcleanLnIncludeAll_
declare -f _wcleanPlatform_
declare -f _wclean_
declare -f _wdep_
declare -f _wmakeCheckPwd_
declare -f _wmakeCollect_
declare -f _wmakeFilesAndOptions_
declare -f _wmakeLnIncludeAll_
declare -f _wmakeLnInclude_
declare -f _wmakePrintBuild_
declare -f _wmakeSchedulerUptime_
declare -f _wmakeScheduler_
declare -f _wmake_
declare -f _writeMeshObj_
declare -f _wrmdep_
declare -f _wrmo_
declare -f _xfunc
declare -f _xinetd_services
declare -f _zipUpMesh_
declare -f command_not_found_handle
declare -f dequote
declare -f foamPV
declare -f foamVersion
declare -f quote
declare -f quote_readline
declare -f wmRefresh
pradip@pms-ubuntu-desktop:~$ ls -l $FOAM_APPBIN/simpleFoam
-rwxr-xr-x 1 root root 746800 Nov 18 09:58 /opt/openfoam7/platforms/linux64GccDPInt32Opt/bin/simpleFoam

pradip@pms-ubuntu-desktop:~$ md5sum $FOAM_APPBIN/simpleFoam
0811701c0bcc0d81a0ba24c6b3c58d33  /opt/openfoam7/platforms/linux64GccDPInt32Opt/bin/simpleFoam
pradip@pms-ubuntu-desktop:~$ md5sum $FOAM_LIBBIN/libOpenFOAM.so
04446cc61790bfbd853224542b7f8127  /opt/openfoam7/platforms/linux64GccDPInt32Opt/lib/libOpenFOAM.so
pradip@pms-ubuntu-desktop:~$ 

wyldckat

2019-12-24 11:34

updater   ~0011002

I've finally managed to test this and from what I can deduce, what happened was something along these lines:

1- There are indications in the output pmsagdeo gave that the commands were typed manually.

2- In Ubuntu 18.04, if we run 'sudo apt install openfoam' instead of 'sudo apt install openfoam7' (namely if we forget the '7' at the end), it will install the package 'openfoam' that is available in Ubuntu, inherited from Debian, which at this time allegedly provides a build of OpenFOAM 4.1, however the build was done in such a way that OpenFOAM still identifies as OpenFOAM 4.0.

3- Now, if OpenFOAM 7 is also installed and the 'source' command is used to load its environment, then OpenFOAM 7 binaries will be picked up without problems (at least from what I could briefly see) and the 4.0 version is ignored.

@pmsagdeo: I suggest you try to remove the OpenFOAM 4 version that might be still installed in your system by accident, by running:

    sudo apt remove openfoam libopenfoam openfoam-examples

This will remove the OpenFOAM installation that is provided by Ubuntu. Simply removing the package 'openfoam' will not be enough, due to how the dependencies in those packages are handled, which is why I had to list all 3 packages in this command. Please keep in mind that these packages provided in Ubuntu and Debian were not packaged by the OpenFOAM Foundation, hence the confusion.

I'm closing this report, since it's solved.

Issue History

Date Modified Username Field Change
2019-12-16 16:22 pmsagdeo New Issue
2019-12-16 16:22 pmsagdeo File Added: OFVersionMismatch121619.jpg
2019-12-16 16:44 henry Note Added: 0010980
2019-12-16 16:50 wyldckat Note Added: 0010981
2019-12-16 19:05 pmsagdeo File Added: OpenFoamInstallation121619
2019-12-16 19:05 pmsagdeo Note Added: 0010982
2019-12-17 09:03 will Note Added: 0010983
2019-12-17 09:04 will Note Edited: 0010983 View Revisions
2019-12-17 10:57 wyldckat Note Added: 0010984
2019-12-17 13:24 pmsagdeo File Added: OpenFoamInstallation121719
2019-12-17 13:24 pmsagdeo Note Added: 0010985
2019-12-17 13:48 wyldckat Note Added: 0010986
2019-12-17 14:18 pmsagdeo File Added: OpenFoamInstallation121719_2
2019-12-17 14:18 pmsagdeo Note Added: 0010988
2019-12-24 11:34 wyldckat Note Added: 0011002
2019-12-24 11:35 wyldckat Assigned To => wyldckat
2019-12-24 11:35 wyldckat Status new => closed
2019-12-24 11:35 wyldckat Resolution open => fixed
2019-12-24 11:35 wyldckat Fixed in Version => 7