View Issue Details

IDProjectCategoryView StatusLast Update
0003401OpenFOAMFeaturepublic2019-11-28 14:40
ReporterClavierAssigned Tohenry 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionno change required 
PlatformLinuxOSUbuntuOS Version18.04
Product Version7 
Fixed in Version 
Summary0003401: Unexpected results with the tutorial offSetCylinder
DescriptionI ran the tutorial 'pimpleFoam/laminar/offSetCylinder' with OpenFOAM-7 and the results appear weird to me.

Without changing any parameter, the solution at the first time step (0.001 s) is given in the attached figure (the boundary conditons are added in the figure).

This looks like a steady solution. According to the simulation, the flow crosses the whole domain in 1 ms. This does not depend on the time step (1e-6 yields about the same result).

If I change the boundary condition on the left from Neumann to Dirichlet on the pressure (P=0), then the flow slowly propagates, which better represents reality. But enforcing two Dirichlet boundary conditions on the pressure and velocity on the same boundary leads to instabilities. All the similar incompressible tutorials present the same feature.

Do the boundary conditions of the tutorial lead to a uniform flow in the whole domain because it is the mathematical solultion of the incompressible Navier-Stokes equations ? If so, how to simulate a genuine transient flow with proper boundary conditions (not P=0 Pa and U=1 m/s on the same boundary) ? I have not found any incompressible tutorial that handles this problem. I think it could be an improvement to add such a tutorial if it is possible.

Thank you

Steps To ReproduceRun the tutorial pimpleFoam/laminar/offSetCylinder
TagsNo tags attached.

Activities

Clavier

2019-11-28 14:12

reporter  

offsetCylinder.png (126,871 bytes)
offsetCylinder.png (126,871 bytes)

tniemi

2019-11-28 14:37

reporter   ~0010944

Hmm, I'm not sure if I understood your problem corretly, but if the simulation is incompressible, there can't be any compression waves propagating as the velocity of such waves would be infinite. The solver has to satisfy continuity, so the velocity will change in the entire domain immediately. For such simulations, you would need to use a compressible solver.

I don't know about this particular tutorial, but the flow can and will became unsteady/turbulent behind obstacles if the velocity is high enough and you simulate it for a while.

henry

2019-11-28 14:40

manager   ~0010945

If you have a fixed velocity inlet and incompressible fluid then because the wave speed is infinite the flow develops instantaneously in principle. If you want transient development you can specify a ramped inlet velocity or run with a pressure rather than a velocity inlet.

Issue History

Date Modified Username Field Change
2019-11-28 14:12 Clavier New Issue
2019-11-28 14:12 Clavier File Added: offsetCylinder.png
2019-11-28 14:37 tniemi Note Added: 0010944
2019-11-28 14:40 henry Assigned To => henry
2019-11-28 14:40 henry Status new => closed
2019-11-28 14:40 henry Resolution open => no change required
2019-11-28 14:40 henry Note Added: 0010945