View Issue Details

IDProjectCategoryView StatusLast Update
0003395OpenFOAMPatchpublic2019-11-24 15:04
Reporterhandrake0724Assigned Tohenry 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
Product Versiondev 
Fixed in Version 
Summary0003395: rigidBodyMeshMotion behavior with linear spring with offset
Descriptioncurrent implementation of rigidBodyMeshMotion applies ramp value to gravity and hydrodynamic forces.
When it comes to free decay simulation or VIM simulation, configuration is set up with linear springs which have sometimes initial offset from the rest length.
In that case, one wants the flows let go while the body does not moved at all until ramp function above zero.
but in the current implementation, the body moves due to the restoring force of the spring even if ramp function value is still zero.
so, ramp function cannot control restraint force. I am not sure if this behavior is intended or not.

in order to apply the ramp effect to restraints also, Just simply introduce conditional such that

in rigidBodyMeshMotion.C:291
        RBD::rigidBodyMotion::solve
        (
            t.value(),
            t.deltaTValue(),
            scalarField(nDoF(), Zero),
            fx
        );

modified into

    if (ramp > 0)
    {
        RBD::rigidBodyMotion::solve
        (
            t.value(),
            t.deltaTValue(),
            scalarField(nDoF(), Zero),
            fx
        );
    }

what do you think about this modification?
TagsNo tags attached.

Activities

henry

2019-11-24 11:49

manager   ~0010936

I am confused by this change, why switch on the value of the ramp being > 0? What should happen if ramp is very small rather than 0? If there is a force which should depend on the ramp shouldn't it depend on it in a continuous manner rather than be switched on it being >0?

handrake0724

2019-11-24 12:45

reporter   ~0010937

my apologies. I have rechecked my simulation setup and found it does not need any changes to rigidBodyMeshMotion class.
I think something went wrong when I tested case and thus modified the code.
Sorry again for bothering you.

henry

2019-11-24 15:04

manager   ~0010938

User error.

Issue History

Date Modified Username Field Change
2019-11-24 11:20 handrake0724 New Issue
2019-11-24 11:49 henry Note Added: 0010936
2019-11-24 12:45 handrake0724 Note Added: 0010937
2019-11-24 15:04 henry Assigned To => henry
2019-11-24 15:04 henry Status new => closed
2019-11-24 15:04 henry Resolution open => no change required
2019-11-24 15:04 henry Note Added: 0010938