View Issue Details

IDProjectCategoryView StatusLast Update
0003386ThirdParty[All Projects] Bugpublic2019-11-26 15:12
ReporterlichuanlongAssigned Tohenry 
PrioritynormalSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version18.04
Product Version7 
Fixed in Version7 
Summary0003386: the guide for compile openfoam need upgrade .
Descriptionhttps://openfoam.org/download/source/software-for-compilation/
In 1st step of compile preview ,there is an setting for qt:
export QT_SELECT=qt4

if qt set to 4, there will be errors when compile preview.

the error like this below.

CMake Error at VTK/CMake/vtkQt.cmake:6 (message):
  Expected value for VTK_QT_VERSION is '5'
Call Stack (most recent call first):
  VTK/GUISupport/Qt/CMakeLists.txt:1 (include)


-- Configuring incomplete, errors occurred!
See also "/home/parallels/myOpenFOAM/ThirdParty-7/build/linux64Gcc/ParaView-5.6.0/CMakeFiles/CMakeOutput.log".
See also "/home/parallels/myOpenFOAM/ThirdParty-7/build/linux64Gcc/ParaView-5.6.0/CMakeFiles/CMakeError.log".
Steps To Reproduceexport QT_SELECT=qt4
and run makeParaView
Additional InformationI think it should be set to 5
export QT_SELECT=qt5
or don't use QT_SELECT
TagsNo tags attached.

Activities

chris

2019-11-18 09:27

manager   ~0010920

Updated the compilation information.
We are using ParaView 5.6.x now, which is not properly supported by the system libraries of Ubuntu 16.04.
So the instructions use a minimum Ubuntu version of 18.04 now and install QT5, deprecating QT4.

Issue History

Date Modified Username Field Change
2019-11-13 01:28 lichuanlong New Issue
2019-11-13 09:54 henry Severity crash => text
2019-11-18 09:27 chris Note Added: 0010920
2019-11-26 15:12 henry Assigned To => henry
2019-11-26 15:12 henry Status new => resolved
2019-11-26 15:12 henry Resolution open => fixed
2019-11-26 15:12 henry Fixed in Version => 7