View Issue Details

IDProjectCategoryView StatusLast Update
0003383OpenFOAMBugpublic2019-12-06 09:54
Reporterpappo1890Assigned Towill 
PriorityhighSeverityminorReproducibilityN/A
Status closedResolutionsuspended 
Product Version 
Fixed in Version 
Summary0003383: LiquidEvaporationBoil spalding number defined on molar basis
DescriptionIn OpenFOAM-2.4.0 at src/lagrangian/intermediate/submodels/Reacting/PhaseChangeModel/LiquidEvaporationBoil/LiquidEvaporationBoil.C
line 318:
dMassPC[lid] += pi d Sh Dab rhos log(1.0 + Xr) dt;
where d is the droplet diameter, Sh is the Sherwood number (Sh(Re,Sc)), Dab the vapor diffusivity assuming properties at the film, rhos the density at the film and Xr (line313):
// molar ratio
const scalar Xr = (Xs - Xc)/max(SMALL, 1.0 - Xs);
The units of dMassPC are in kg. However, the dimensionless group Xr is expressed in terms of molar fractions.
In literature, Xr is better known as the Spalding mass number (BM) where the ratio is expressed in terms of mass fractions rather than molar fractions [1,2]
I wonder if there is an implementation reason, which I do not see immediately, or if this is an implementation issue that should be fixed in order to correctly predict the evaporation rate.
Thank you in advance for your support and reply.
Alessandro
[1] Sergei S. Sazhin, Advanced models of fuel droplet heating and evaporation, Progress in Energy and Combustion Science, Volume 32, Issue 2, 2006.
[2] Patrick Jenny, Dirk Roekaerts, Nijso Beishuizen, Modeling of turbulent dilute spray combustion, Progress in Energy and Combustion Science, Volume 38, Issue 6, 2012.
TagsNo tags attached.

Activities

will

2019-11-12 09:20

manager   ~0010886

Last edited: 2019-11-12 09:21

View 2 revisions

The evaporation model is not referenced, but the calculation process seems to be approximately this: https://en.wikipedia.org/wiki/Droplet_vaporization (please correct me if I am wrong).

The choice of mass or mole fraction then depends on what you consider to be the property who's gradient the the mass transfer rate is proportional to. Both mass and mole fraction are approximate. Mass or molar concentration are also potentially valid options (also maybe partial pressure?). All are proportional to each other. The difference is in the linearisation; i.e., the coefficient that is used to convert between them and which is considered constant for the purposes of calculating gradients/differences.

As both options are potentially valid, if you want to change from mole to mass fraction you will have to supply us some evidence that the latter is more accurate. Some sort of single-droplet evaporation case with an experimental comparison would be sufficient.

pappo1890

2019-11-18 07:49

reporter   ~0010918

Thank you for your reply.

I have opened a similar discussion here: https://develop.openfoam.com/Development/OpenFOAM-plus/issues/1489
I think both replies are in line with the implementation strategy adopted in OpenFOAM.

will

2019-11-21 16:38

manager   ~0010933

The linked discussion did not conclude one way or the other. Have you further evidence to support this change, or should I close the report?

pappo1890

2019-11-22 11:10

reporter   ~0010935

Indeed, I am trying to provide some evidence to support the suggested change by deriving both expressions. If it is possible I would like to keep the report open for one more week.

will

2019-12-06 09:54

manager   ~0010965

It's now been two more weeks, so closing. Please open a new report if/when you gather the appropriate evidence.

Issue History

Date Modified Username Field Change
2019-11-11 10:00 pappo1890 New Issue
2019-11-12 09:20 will Note Added: 0010886
2019-11-12 09:21 will Note Edited: 0010886 View Revisions
2019-11-18 07:49 pappo1890 Note Added: 0010918
2019-11-21 16:38 will Note Added: 0010933
2019-11-22 11:10 pappo1890 Note Added: 0010935
2019-12-06 09:54 will Assigned To => will
2019-12-06 09:54 will Status new => closed
2019-12-06 09:54 will Resolution open => suspended
2019-12-06 09:54 will Note Added: 0010965