View Issue Details

IDProjectCategoryView StatusLast Update
0003362OpenFOAMBugpublic2019-10-08 16:31
Reporterhosseinheydari2013Assigned Tohenry 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionno change required 
PlatformGNU/LinuxOSOpenSuSE LeapOS Version42.3
Product Version7 
Fixed in Version 
Summary0003362: adding/removing layers not working for 3d cases
DescriptionI have been working with movingConeFvMesh for the past 3 days and I couldn't get it right for the case of a piston compression.
geometry is simply a cylinder. faceZones are generated with topoSet. And the solver is interFoam (it can be any other solver)

it seems that addition/removal of layers does NOT work for 3d cases. I have tried the same procedure with movingCone tutorial (2d) and it works fine. However, for this case of piston compression deletion of the layers doesn't work which results into a very thin cell size and eventually divergence of the solver.

A sample test case is attached. And steps are given to reproduce the issue.
The result of this sample test is shown in a .gif which is attached separately due to size limits on upload.
Steps To Reproduce1. unzip the test case (movingMeshCase.zip)
2. topoSet
3. interFoam
TagsNo tags attached.

Activities

hosseinheydari2013

2019-10-08 16:20

reporter  

movingMeshCase.zip (1,787,814 bytes)

hosseinheydari2013

2019-10-08 16:22

reporter   ~0010812

animation for the reported issue

movingMesh.ogv.gif (512,471 bytes)

henry

2019-10-08 16:31

manager   ~0010813

User support request.

Issue History

Date Modified Username Field Change
2019-10-08 16:20 hosseinheydari2013 New Issue
2019-10-08 16:20 hosseinheydari2013 File Added: movingMeshCase.zip
2019-10-08 16:22 hosseinheydari2013 File Added: movingMesh.ogv.gif
2019-10-08 16:22 hosseinheydari2013 Note Added: 0010812
2019-10-08 16:31 henry Assigned To => henry
2019-10-08 16:31 henry Status new => closed
2019-10-08 16:31 henry Resolution open => no change required
2019-10-08 16:31 henry Note Added: 0010813