View Issue Details

IDProjectCategoryView StatusLast Update
0003360OpenFOAMBugpublic2019-10-09 13:08
ReporterhofbeerAssigned Towill 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version 
Fixed in Version 
Summary0003360: Abnormal temperature of rhoReactingBuoyantFoam when the gravity sign changed.
DescriptionHello

I have a buoyant issue about rhoReactingBuoyantFoam.
My case is premixed flame propagation in open – open tube.
My mesh is 2D axis-symmetric along x-direction.

If I change the gravity sign, g =(9.81 0 0) → g=(-9.81 0 0), abnormal temperature occurs when the flame touches the wall. It works fine for positive g, But it blows up negative g.

This is strange to me since my case is symmetric with respect to y-z plane at the center of the tube. So there is no directional preference along the x-direction. I gave the same boundary and initial condition to two ends and ignited at the center of tube.

Is there gravity sign preference for rhoReactingBuoyantFoam ?

Thank you for your help

My environment: Ubuntu 16.04, OpenFOAM-4.1
Steps To Reproduce1) Edit gravity sign: constant/g
2) run rhoReactingBuoyantFoam
3) The abnormal temperature will occur at t ~ 0.014 sec if the sign is negative
TagsNo tags attached.

Activities

hofbeer

2019-10-04 10:43

reporter  

image.png (48,249 bytes)
image.png (48,249 bytes)

hofbeer

2019-10-04 10:44

reporter  

buoyant_issue.tar (1,402,880 bytes)

henry

2019-10-04 10:49

manager   ~0010795

>Is there gravity sign preference for rhoReactingBuoyantFoam ?

No

hofbeer

2019-10-04 11:06

reporter   ~0010796

Yes, I think that is natural. But I can't understand this situation ...

wyldckat

2019-10-07 10:49

updater   ~0010801

@hofbeer: X is defined from 0 to 200. This means that it has a gravitational reference that is different on the vector, since when g=-9.81 means that there is 0.2m of fluid weight on the domain, while on g=+9.81, it decreases with 'distance' to 0.

   p_rgh = p - rho*g*height

this is what is different in your case.

Furthermore, notice how the pressure fields are initialized: https://github.com/OpenFOAM/OpenFOAM-7/blob/master/applications/solvers/combustion/reactingFoam/rhoReactingBuoyantFoam/createFields.H#L89

will

2019-10-09 13:08

manager   ~0010822

Confirmed. With hRef equal to 0.2 the case runs identically with the gravity sign changed. Closing.

Issue History

Date Modified Username Field Change
2019-10-04 10:43 hofbeer New Issue
2019-10-04 10:43 hofbeer File Added: image.png
2019-10-04 10:44 hofbeer File Added: buoyant_issue.tar
2019-10-04 10:49 henry Note Added: 0010795
2019-10-04 11:06 hofbeer Note Added: 0010796
2019-10-07 10:49 wyldckat Note Added: 0010801
2019-10-09 13:08 will Assigned To => will
2019-10-09 13:08 will Status new => closed
2019-10-09 13:08 will Resolution open => no change required
2019-10-09 13:08 will Note Added: 0010822