View Issue Details

IDProjectCategoryView StatusLast Update
0003340OpenFOAMBugpublic2019-08-28 21:15
ReportersitadrostAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
PlatformGNU/LinuxOSScientific LinuxOS Version7.3
Product Version7 
Fixed in Version 
Summary0003340: restart with rigidBodyMotion crashes
DescriptionThe bug reported and resolved in issue 0003288 seems to be present in OpenFOAM-7, too:

Restarting a rigidBodyMotion case crashes with the following error message:

--> FOAM FATAL ERROR:
Not implemented

    From function virtual Foam::Istream& Foam::ITstream::read(char*, std::streamsize)
    in file db/IOstreams/Tstreams/ITstream.C at line 159.

FOAM aborting

#0 Foam::error::printStack(Foam::Ostream&) at ??:?
#1 Foam::error::abort() at ??:?
#2 Foam::ITstream::read(char*, long) at ??:?
#3 Foam::Istream& Foam::operator>><double>(Foam::Istream&, Foam::List<double>&) at ??:?
#4 Foam::Field<double> Foam::dictionary::lookupOrDefault<Foam::Field<double> >(Foam::word const&, Foam::Field<double> const&, bool, bool) const at ??:?
#5 Foam::RBD::rigidBodyModelState::rigidBodyModelState(Foam::RBD::rigidBodyModel const&, Foam::dictionary const&) at ??:?
#6 Foam::RBD::rigidBodyMotion::rigidBodyMotion(Foam::dictionary const&, Foam::dictionary const&) at ??:?
#7 Foam::rigidBodyMeshMotion::rigidBodyMeshMotion(Foam::polyMesh const&, Foam::dictionary const&) at ??:?
#8 Foam::motionSolver::adddictionaryConstructorToTable<Foam::rigidBodyMeshMotion>::New(Foam::polyMesh const&, Foam::dictionary const&) at ??:?
#9 Foam::motionSolver::New(Foam::polyMesh const&, Foam::dictionary const&) at ??:?
#10 Foam::dynamicMotionSolverFvMesh::dynamicMotionSolverFvMesh(Foam::IOobject const&) at ??:?
#11 Foam::dynamicFvMesh::addIOobjectConstructorToTable<Foam::dynamicMotionSolverFvMesh>::New(Foam::IOobject const&) at ??:?
#12 Foam::dynamicFvMesh::New(Foam::IOobject const&) at ??:?
#13 ? at ??:?
#14 __libc_start_main in "/lib/x86_64-linux-gnu/libc.so.6"
#15 ? at ??:?
Aborted
Steps To ReproduceRun any case with dynamicMeshDict using rigidBodyMotion, restart from latestTime.
TagsNo tags attached.

Activities

henry

2019-08-27 07:59

manager   ~0010702

I am unable to reproduce this problem, the fix from issue 0003288 is in OpenFOAM-7 already. I have run the floatingObject tutorial in OpenFOAM-7 and restarted it without problem.
You will need to provide more details of how you generated this error.

sitadrost

2019-08-28 07:56

reporter   ~0010704

I'm sorry, it's probably something on our cluster. When I run a small case on the master node, like the floatingObject tutorial, it restarts without problems. The error I reported above came up after restarting a bigger case on the cluster, so perhaps some old bits of a previous OpenFOAM install are still hidden there somewhere. My apologies for bothering you with this!

Issue History

Date Modified Username Field Change
2019-08-27 07:22 sitadrost New Issue
2019-08-27 07:59 henry Note Added: 0010702
2019-08-28 07:56 sitadrost Note Added: 0010704
2019-08-28 21:15 henry Assigned To => henry
2019-08-28 21:15 henry Status new => closed
2019-08-28 21:15 henry Resolution open => no change required