View Issue Details

IDProjectCategoryView StatusLast Update
0003325OpenFOAMPatchpublic2019-08-10 16:30
ReportertniemiAssigned Tohenry 
PrioritylowSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
Product Versiondev 
Fixed in Versiondev 
Summary0003325: Patch for some misc. typos and inconsistencies
DescriptionI have attached a patch which fixes a couple of typos in several files. In distributionModel.H, the description contains a typo "unifrom", but the message itself is quite misleading, because only the uniform distribution uses tabulation and it doesn't need to be equidistant.

In ReactingParcel.C, the hmm scalarField appears to be completely unused.
TagsNo tags attached.

Activities

tniemi

2019-08-10 15:15

reporter  

patch.diff (4,143 bytes)
diff --git a/applications/solvers/multiphase/reactingEulerFoam/phaseSystems/diameterModels/diameterModel/diameterModel.H b/applications/solvers/multiphase/reactingEulerFoam/phaseSystems/diameterModels/diameterModel/diameterModel.H
index 0c66e13..c0c89fb 100644
--- a/applications/solvers/multiphase/reactingEulerFoam/phaseSystems/diameterModels/diameterModel/diameterModel.H
+++ b/applications/solvers/multiphase/reactingEulerFoam/phaseSystems/diameterModels/diameterModel/diameterModel.H
@@ -25,7 +25,7 @@ Class
     Foam::diameterModel
 
 Description
-    A2stract base-class for dispersed-phase particle diameter models.
+    Abstract base-class for dispersed-phase particle diameter models.
 
 SourceFiles
     diameterModel.C
diff --git a/applications/solvers/multiphase/twoPhaseEulerFoam/twoPhaseSystem/diameterModels/diameterModel/diameterModel.H b/applications/solvers/multiphase/twoPhaseEulerFoam/twoPhaseSystem/diameterModels/diameterModel/diameterModel.H
index f447cec..19c3faa 100644
--- a/applications/solvers/multiphase/twoPhaseEulerFoam/twoPhaseSystem/diameterModels/diameterModel/diameterModel.H
+++ b/applications/solvers/multiphase/twoPhaseEulerFoam/twoPhaseSystem/diameterModels/diameterModel/diameterModel.H
@@ -25,7 +25,7 @@ Class
     Foam::diameterModel
 
 Description
-    A2stract base-class for dispersed-phase particle diameter models.
+    Abstract base-class for dispersed-phase particle diameter models.
 
 SourceFiles
     diameterModel.C
diff --git a/applications/solvers/multiphase/twoPhaseEulerFoam/twoPhaseSystem/phaseModel/phaseModel.H b/applications/solvers/multiphase/twoPhaseEulerFoam/twoPhaseSystem/phaseModel/phaseModel.H
index f0d2901..ea6b606 100644
--- a/applications/solvers/multiphase/twoPhaseEulerFoam/twoPhaseSystem/phaseModel/phaseModel.H
+++ b/applications/solvers/multiphase/twoPhaseEulerFoam/twoPhaseSystem/phaseModel/phaseModel.H
@@ -208,14 +208,14 @@ public:
             return thermo_->alpha(patchi);
         }
 
-        //- Thermal diffusivity for temperature of mixture [W/m/K]
+        //- Thermal diffusivity for temperature of mixture
+        //  for patch [W/m/K]
         tmp<scalarField> kappa(const label patchi) const
         {
             return thermo_->kappa(patchi);
         }
 
-        //- Thermal diffusivity for temperature of mixture
-        //  for patch [W/m/K]
+        //- Thermal diffusivity for temperature of mixture [W/m/K]
         tmp<volScalarField> kappa() const
         {
             return thermo_->kappa();
diff --git a/src/lagrangian/distributionModels/distributionModel/distributionModel.H b/src/lagrangian/distributionModels/distributionModel/distributionModel.H
index b93e1f2..7cfa2c6 100644
--- a/src/lagrangian/distributionModels/distributionModel/distributionModel.H
+++ b/src/lagrangian/distributionModels/distributionModel/distributionModel.H
@@ -39,11 +39,6 @@ Description
     - Mass-based Rosin-Rammler
     - uniform
 
-    The distributionModel is tabulated in equidistant nPoints, in an interval.
-    These values are integrated to obtain the cumulated distribution model,
-    which is then used to change the distribution from unifrom to
-    the actual distributionModel.
-
 SourceFiles
     distributionModel.C
     distributionModelNew.C
@@ -146,7 +141,7 @@ public:
         //- Return the maximum value
         virtual scalar maxValue() const = 0;
 
-        //- Return the maximum value
+        //- Return the mean value
         virtual scalar meanValue() const = 0;
 };
 
diff --git a/src/lagrangian/intermediate/parcels/Templates/ReactingParcel/ReactingParcel.C b/src/lagrangian/intermediate/parcels/Templates/ReactingParcel/ReactingParcel.C
index 9c7657b..4b74db6 100644
--- a/src/lagrangian/intermediate/parcels/Templates/ReactingParcel/ReactingParcel.C
+++ b/src/lagrangian/intermediate/parcels/Templates/ReactingParcel/ReactingParcel.C
@@ -80,8 +80,6 @@ void Foam::ReactingParcel<ParcelType>::calcPhaseChange
     const scalar Tdash = min(T, TMax);
     const scalar Tsdash = min(Ts, TMax);
 
-    scalarField hmm(dMassPC);
-
     // Calculate mass transfer due to phase change
     phaseChange.calculate
     (
patch.diff (4,143 bytes)

henry

2019-08-10 16:30

manager   ~0010668

Resolved by commit 3dfbbdbfe90da23a400d72939d50bda530474fde

Issue History

Date Modified Username Field Change
2019-08-10 15:15 tniemi New Issue
2019-08-10 15:15 tniemi File Added: patch.diff
2019-08-10 16:30 henry Assigned To => henry
2019-08-10 16:30 henry Status new => resolved
2019-08-10 16:30 henry Resolution open => fixed
2019-08-10 16:30 henry Fixed in Version => dev
2019-08-10 16:30 henry Note Added: 0010668