View Issue Details

IDProjectCategoryView StatusLast Update
0003309OpenFOAMBugpublic2019-07-19 11:52
Reporteralish1984Assigned Towill 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version18.04
Product Version6 
Fixed in Versiondev 
Summary0003309: Lagrangian fields cloud scattering coefficient is always zero
DescriptionIt seems that when using "cloudScatter" as a scatterModel in radiation modelling, sigmaEff (the scattering of particles) is always zero.
The reason:
In ThermoParcelI.H where this cloudScatter is computed in sigmap() function:
tsigmap is declared and its value is set to zero. Then in the last line before "return" we have:
sigmap *= sumAreaP*(1.0 - f)*(1.0 - epsilon)/V/dt;

So it is always zero, because it is multiplied by zero. I don't know why multiplication has been used. I think it should be simply:
sigmap = sumAreaP*(1.0 - f)*(1.0 - epsilon)/V/dt;
Honestly, I did not reproduce the bug in OF6 because I don't have the code compiled so I can not simply print the field (currently I am using 2.4.x.). However, the bug is the same in all versions, because the same line of the code has been used in the new versions.

Am I correct or I understood it wrongly? You can test it by simply printing the variable while running the tutorial "simplifiedSiwek". I did it for 2.4.x.
TagsNo tags attached.

Activities

will

2019-07-19 11:52

manager   ~0010615

You are correct, the implementation is wrong. Thanks for letting us know. Fixed in dev by https://github.com/OpenFOAM/OpenFOAM-dev/commit/7e65281f60923e0c3d3dc545a505f6445760b961.

Issue History

Date Modified Username Field Change
2019-07-19 09:55 alish1984 New Issue
2019-07-19 11:52 will Assigned To => will
2019-07-19 11:52 will Status new => resolved
2019-07-19 11:52 will Resolution open => fixed
2019-07-19 11:52 will Fixed in Version => dev
2019-07-19 11:52 will Note Added: 0010615