View Issue Details

IDProjectCategoryView StatusLast Update
0003305OpenFOAMBugpublic2019-07-15 14:40
ReporterSahasAssigned Towill 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSOtherOS Version(please specify)
Product Versiondev 
Fixed in Version7 
Summary0003305: Problem with TomiyamaLiftForce in Lagrangian module
DescriptionIn the calculation procedure for TomiyamaLiftForce, Eotvos number is used in pow operation (see src/lagrangian/intermediate/submodels/Kinematic/ParticleForces/Lift/TomiyamaLift/TomiyamaLiftForce.C)
But Eotvos number can be negative due to its definition (see src/lagrangian/intermediate/parcels/Templates/KinematicParcel/KinematicParcelI.H):
return mag(g & dir)*(rho - rhoc)*sqr(d)/max(sigma, rootVSmall);
Here, (rho - rhoc) becomes negative if particle density is less than rhoc.
Steps To ReproduceRun DPMFoam with TomiyamaLiftForce enabled and particle density set less than fluid density.
TagsNo tags attached.

Activities

Issue History

Date Modified Username Field Change
2019-07-13 09:43 Sahas New Issue
2019-07-15 09:07 will Assigned To => will
2019-07-15 09:07 will Status new => resolved
2019-07-15 09:07 will Resolution open => fixed
2019-07-15 09:07 will Fixed in Version => dev
2019-07-15 09:07 will Note Added: 0010560
2019-07-15 14:40 will Note Added: 0010564
2019-07-15 14:40 will Fixed in Version dev => 7