View Issue Details

IDProjectCategoryView StatusLast Update
0003284OpenFOAMBugpublic2019-05-30 16:37
ReporterjmtiscarAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformGNU/LinuxOSUbuntuOS Version16.04 ,18.04
Product Version6 
Fixed in Versiondev 
Summary0003284: blockMesh fails building two collapsed vertex with determined number of cells.
DescriptionblockMesh fails when I tried to build a geometry with triple and double collapsed vertex. When the number of cells is the same in all directions all it's okey. However, when I change the number of cells OpenFoam 6.0 complains. I checked that the same configuration works well in OpenFOAM 5.x

The most common error is the following:

--> FOAM FATAL ERROR:
Inconsistent point locations between block pair 0 and 1
    probably due to inconsistent grading.

    From function void Foam::blockMesh::calcMergeInfo()
    in file blockMesh/blockMeshMerge.C at line 294.

FOAM exiting

In other geometries I have prepared, OpenFOAM reports the following error:

--> FOAM FATAL ERROR:
face 598 in patch 0 does not have neighbour cell face: 4(813 1164 813 1327)

    From function Foam::labelList Foam::polyMesh::facePatchFaceCells(const faceList&, const labelListList&, const faceListList&, Foam::label) const
    in file meshes/polyMesh/polyMeshFromShapeMesh.C at line 118.

FOAM aborting

#0 Foam::error::printStack(Foam::Ostream&) at ??:?
#1 Foam::error::abort() at ??:?
#2 Foam::polyMesh::facePatchFaceCells(Foam::List<Foam::face> const&, Foam::List<Foam::List<int> > const&, Foam::List<Foam::List<Foam::face> > const&, int) const at ??:?
#3 Foam::polyMesh::setTopology(Foam::List<Foam::cellShape> const&, Foam::List<Foam::List<Foam::face> > const&, Foam::List<Foam::word> const&, Foam::List<int>&, Foam::List<int>&, int&, int&, Foam::List<Foam::cell>&) at ??:?
#4 Foam::polyMesh::polyMesh(Foam::IOobject const&, Foam::Xfer<Foam::Field<Foam::Vector<double> > > const&, Foam::List<Foam::cellShape> const&, Foam::List<Foam::List<Foam::face> > const&, Foam::List<Foam::word> const&, Foam::PtrList<Foam::dictionary> const&, Foam::word const&, Foam::word const&, bool) at ??:?
#5 ? at ??:?
#6 __libc_start_main in "/lib/x86_64-linux-gnu/libc.so.6"
#7 ? at ??:?
Abortado (`core' generado)
Steps To Reproduce-Run blockMesh (OpenFOAM 6.0) on the case I attach.
Additional InformationIf you run blockMesh (OpenFOAM 5.x) on the case I attach, you can notice a correct behaviour.
TagsNo tags attached.

Relationships

duplicate of 0003233 resolvedhenry blockMesh false faces on axis in wedge block continued 

Activities

jmtiscar

2019-05-30 12:07

reporter  

testBM.rar (779,733 bytes)

henry

2019-05-30 12:23

manager   ~0010501

This is probably the same issue reported and fixed:

commit 5ed7aa35fbc9951ddff33fb07471d6f7d82ebdd3
Author: Henry Weller <http://openfoam.org>
Date: Fri May 17 11:24:12 2019 +0100

    blockMeshMerge: Increased merge tolerance
    
    Resolves bug-report https://bugs.openfoam.org/view.php?id=3233

commit f0c3c497e7d0945f69078cb1751751dd0e542ce5
Author: Henry Weller <http://openfoam.org>
Date: Tue Mar 19 16:38:37 2019 +0000

    blockMeshMerge: Changed the mergeSqrDist slightly to compensate for the change SMALL -> small
    
    Resolves bug-report https://bugs.openfoam.org/view.php?id=3203

Try with the latest OpenFOAM-dev and if that resolves the issue I will make the same change to OpenFOAM-6

jmtiscar

2019-05-30 12:39

reporter   ~0010502

The problem still exists, however, the report is now different. I used OpenFOAM-dev Build: dev-5420c5001b2e (Ubuntu 46.04 --Windows 10 bash)

--> FOAM FATAL ERROR:
face 2860 in patch 0 does not have neighbour cell face: 4(5661 5 5661 5)

    From function Foam::labelList Foam::polyMesh::facePatchFaceCells(const faceList&, const labelListList&, const faceListList&, Foam::label) const
    in file meshes/polyMesh/polyMeshFromShapeMesh.C at line 118.

FOAM aborting

#0 Foam::error::printStack(Foam::Ostream&) at ??:?
#1 Foam::error::abort() at ??:?
#2 Foam::polyMesh::facePatchFaceCells(Foam::List<Foam::face> const&, Foam::List<Foam::List<int> > const&, Foam::List<Foam::List<Foam::face> > const&, int) const at ??:?
#3 Foam::polyMesh::setTopology(Foam::List<Foam::cellShape> const&, Foam::List<Foam::List<Foam::face> > const&, Foam::List<Foam::word> const&, Foam::List<int>&, Foam::List<int>&, int&, int&, Foam::List<Foam::cell>&) at ??:?
#4 Foam::polyMesh::polyMesh(Foam::IOobject const&, Foam::Xfer<Foam::Field<Foam::Vector<double> > > const&, Foam::List<Foam::cellShape> const&, Foam::List<Foam::List<Foam::face> > const&, Foam::List<Foam::word> const&, Foam::PtrList<Foam::dictionary> const&, Foam::word const&, Foam::word const&, bool) at ??:?
#5 ? at ??:?
#6 __libc_start_main in "/lib/x86_64-linux-gnu/libc.so.6"
#7 ? at ??:?

henry

2019-05-30 12:48

manager   ~0010503

Could you try with the latest OpenFOAM-dev, commit 5420c5001b2e predates commit 5ed7aa35fbc9951ddff33fb07471d6f7d82ebdd3

jmtiscar

2019-05-30 13:10

reporter   ~0010504

Sorry, I didn't update the repository. Now it is working perfectly. OpenFOAM-dev Build: dev-30bea84facb2

Thanks!!

Issue History

Date Modified Username Field Change
2019-05-30 12:07 jmtiscar New Issue
2019-05-30 12:07 jmtiscar File Added: testBM.rar
2019-05-30 12:23 henry Note Added: 0010501
2019-05-30 12:39 jmtiscar Note Added: 0010502
2019-05-30 12:48 henry Note Added: 0010503
2019-05-30 13:10 jmtiscar Note Added: 0010504
2019-05-30 16:37 henry Assigned To => henry
2019-05-30 16:37 henry Status new => closed
2019-05-30 16:37 henry Resolution open => duplicate
2019-05-30 16:37 henry Fixed in Version => dev
2019-05-30 16:37 henry Relationship added duplicate of 0003233