View Issue Details

IDProjectCategoryView StatusLast Update
0003236OpenFOAMFeaturepublic2019-05-13 13:15
ReporterTongdongqAssigned Tohenry 
PrioritylowSeverityfeatureReproducibilityN/A
Status closedResolutionno change required 
PlatformUnixOSUbuntuOS Version18.04
Product Version6 
Fixed in Version 
Summary0003236: Partial compilation possible?
DescriptionI'm trying to insert some debugging code, like size of the matrix, and timing pieces of code in OpenFOAM.
For the time being, I'll only use a particular example (incompressible/icoFoam/cavity) and thus only one solver (icoFoam).
Since running Allwmake in $WM_PROJECT_DIR takes a long time (1-2h), I would like to compile the least amount to be able to run this example.
I noticed Allwmake first compiles src/, and then applications/, given that icoFoam is in applications/, it might be possible to change application/Allwmake to only compile icoFoam.
Is it possible to reduce the compiletime for my usecase?
TagsNo tags attached.

Issue History

Date Modified Username Field Change
2019-05-13 12:57 Tongdongq New Issue
2019-05-13 13:15 henry Assigned To => henry
2019-05-13 13:15 henry Status new => closed
2019-05-13 13:15 henry Resolution open => no change required
2019-05-13 13:15 henry Note Added: 0010463