View Issue Details

IDProjectCategoryView StatusLast Update
0003225OpenFOAMBugpublic2019-04-21 13:28
Reporterhua jiAssigned Tohenry 
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version12.04
Product Version6 
Fixed in Versiondev 
Summary0003225: results are quite different
DescriptionHello,

I ran the same tutorial case: nozzleflow2d which is located in $FOAM_TUTORIALS/multiphase/interfoam/les/nozzleflow2d with openfoam 5.0 and openfoam 6.0, respectively. However, I got quite different results, as shown below. I think that the results from openfoam 5.0 are more reasonable to me. Does anybody know the reason? Thanks.

Hua Ji
TagsNo tags attached.

Activities

hua ji

2019-04-21 10:54

reporter  

henry

2019-04-21 13:28

manager   ~0010436

The difference is due to the change in ddtPhiCorrCoeff which was required for some cases running with a VERY small Courant number. However other cases have responded badly to this change and it has been reverted in OpenFOAM-dev pending further testing and development.

To obtain results more similar to those from 5.x upgrade to OpenFOAM-dev.

Issue History

Date Modified Username Field Change
2019-04-21 10:54 hua ji New Issue
2019-04-21 10:54 hua ji File Added: nozzleflow2d_openfoam_5_0.png
2019-04-21 10:54 hua ji File Added: nozzleflow2d_openfoam_6_0.png
2019-04-21 11:15 henry Priority urgent => low
2019-04-21 11:15 henry Severity major => minor
2019-04-21 11:15 henry Description Updated View Revisions
2019-04-21 13:28 henry Assigned To => henry
2019-04-21 13:28 henry Status new => closed
2019-04-21 13:28 henry Resolution open => fixed
2019-04-21 13:28 henry Fixed in Version => dev
2019-04-21 13:28 henry Note Added: 0010436