View Issue Details

IDProjectCategoryView StatusLast Update
0003153OpenFOAMPatchpublic2019-01-28 09:56
Reporterhandrake0724Assigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSArchOS Version(please specify)
Product Versiondev 
Fixed in Versiondev 
Summary0003153: Request to rename MVAPICH2
DescriptionI guess keyword MVAPICH2 for supporting MVAPICH2 mpi should be renamed.
currently, MVAPICH2 is reserved in WM_MPLIB value for MVAPICH2 as shown in etc/config.sh/mpi

However, this keyword does not work for Pstream compilation because the keyword should be a *MPI* as shown in src/Pstream/Allwclean.
As such, current configuration for MVAPICH2 cannot compile Pstream properly.

Maybe MV2MPI or something would be fine. As a result, mplibMVAPICH2 in wmake/rules/General would be subject to change.

TagsNo tags attached.

Activities

henry

2019-01-28 09:56

manager   ~0010266

resolved by commit 51a8b15afe3fcebf6d3cecc20a9f0d8e6f3dff73

Issue History

Date Modified Username Field Change
2019-01-28 05:44 handrake0724 New Issue
2019-01-28 09:56 henry Category Bug => Patch
2019-01-28 09:56 henry Summary typo in MVAPICH2 support => Request to rename MVAPICH2
2019-01-28 09:56 henry Assigned To => henry
2019-01-28 09:56 henry Status new => resolved
2019-01-28 09:56 henry Resolution open => fixed
2019-01-28 09:56 henry Fixed in Version => dev
2019-01-28 09:56 henry Note Added: 0010266