View Issue Details

IDProjectCategoryView StatusLast Update
0003146OpenFOAMFeaturepublic2019-01-14 12:56
ReporterjherbAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSOtherOS Version(please specify)
Product Versiondev 
Fixed in Versiondev 
Summary0003146: Mass source term in chtMultiRegionFoam
DescriptionAs discussed in this forum thread (https://www.cfd-online.com/Forums/openfoam-pre-processing/212249-mass-source-term-chtmultiregionfoam.html), it is currently not possible to add a mass source term with fvOptions for the solver chtMultiRegionFoam.

The reason seams to be, that the corresponding term is missing in the pressure equation:

        fvScalarMatrix p_rghEqn
        (
            p_rghEqnComp + p_rghEqnIncomp
          ==
          + fvOptions(psi, p_rgh, rho.name())
        );
Steps To ReproduceAdd a mass source term (only) to the continuity equation.
No effect is seen in the simulation.

Change the solver and add the source term also to the pressure equation.
Should work as expected.
TagsNo tags attached.

Activities

wyldckat

2019-01-14 12:44

updater   ~0010254

@Henry: Since this is already in commit 953e725eb583b5779f215df86f253f79b5f0b5ba on OpenFOAM-dev (https://github.com/OpenFOAM/OpenFOAM-dev/commit/953e725eb583b5779f215df86f253f79b5f0b5ba ), I don't know if there is anything else to be done for this report?

henry

2019-01-14 12:56

manager   ~0010255

Resolved by commit 953e725eb583b5779f215df86f253f79b5f0b5ba

Issue History

Date Modified Username Field Change
2019-01-01 17:58 jherb New Issue
2019-01-14 12:43 wyldckat Assigned To => henry
2019-01-14 12:43 wyldckat Status new => assigned
2019-01-14 12:44 wyldckat Note Added: 0010254
2019-01-14 12:56 henry Status assigned => resolved
2019-01-14 12:56 henry Resolution open => fixed
2019-01-14 12:56 henry Fixed in Version => dev
2019-01-14 12:56 henry Note Added: 0010255