View Issue Details

IDProjectCategoryView StatusLast Update
0003145OpenFOAMBugpublic2019-01-04 14:57
ReporterjskortelAssigned Towill 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
PlatformGNU/LinuxOSUbuntuOS Version18.04 LTS
Product Versiondev 
Fixed in Version 
Summary0003145: ACMI with linear mesh motion and deforming mesh not working with the displacementLaplacian motion solver
DescriptionThis issue is closely related to issue "0002057: ACMI incompatible with velocityComponentLaplacian" but in this one the motion solver is displacementLaplacian. When running a case with linear mesh motion and deforming mesh (e.g. a two-stroke engine), the mesh gets mangled and finally the solver crashes.

Attached is a simple and coarse test case for ACMI with deforming mesh and linear mesh motion with displacementLaplacian motion solver. Running the case with the pimpleFoam solver should illustrate the issue. In addition, the attached video points out the issue with the mesh.
Steps To Reproduce1. Untar the test case package.
2. Run the case with the pimpleFoam solver.
3. Check the results and especially the mesh deformation in the sliding interface area.
Additional InformationThe issue is related to issues ID 0003144 and 0002057
TagsNo tags attached.

Activities

jskortel

2018-12-31 11:53

reporter  

motionDisplacementLaplacian.tgz (204,347 bytes)

henry

2018-12-31 12:03

manager   ~0010246

Work on AMI and ACMI requires funding, see

https://openfoam.org/news/funding-2019/
https://openfoam.org/maintenance/

will

2019-01-04 14:57

manager   ~0010253

Last edited: 2019-01-04 14:57

View 2 revisions

The case is missing a cellDIsplacement field. See https://bugs.openfoam.org/view.php?id=2057#c10101

Issue History

Date Modified Username Field Change
2018-12-31 11:53 jskortel New Issue
2018-12-31 11:53 jskortel File Added: motionDisplacementLaplacian.tgz
2018-12-31 12:03 henry Note Added: 0010246
2019-01-04 14:57 will Assigned To => will
2019-01-04 14:57 will Status new => closed
2019-01-04 14:57 will Resolution open => no change required
2019-01-04 14:57 will Note Added: 0010253
2019-01-04 14:57 will Note Edited: 0010253 View Revisions