View Issue Details

IDProjectCategoryView StatusLast Update
0003141OpenFOAMBugpublic2018-12-31 16:25
Reporterdominic.chandarAssigned Tohenry 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformGNU/LinuxOSUbuntuOS Version15.04
Product Version5.x 
Fixed in Version 
Summary0003141: Moment calculation defaults to Zero Centre of Rotation, rigidBodyDynamics
Descriptionin OpenFOAM/src/rigidBodyMeshMotion/rigidBodyMeshMotion/rigidBodyMeshMotion.C : 282

forcesDict.add("CofR", vector::zero);

The Centre of rotation seems to default to vector::zero in contrast with the older sixDoF library ( OpenFOAM/src/sixDoFRigidBodyMotion/sixDoFRigidBodyMotionSolver/sixDoFRigidBodyMotionSolver.C: 223)

forcesDict.add("CofR", motion_.centreOfRotation());
Additional InformationPresent in 4.x, 5.0, 5.x, dev versions
TagsNo tags attached.

Activities

henry

2018-12-27 08:18

manager   ~0010235

What is the consequence of this difference? Which do you prefer? Do you have any cases which show a difference in behavior? Steps to reproduce etc.?

dominic.chandar

2018-12-27 08:29

reporter   ~0010236

Let's say I have a simple blade whose hub or centre is located at a point (5,5,5) and I am computing the rotation from the moments (Torque) (1-DoF motion). With a zero centre of rotation, the moments would be incorrect. Instead, the moments have to be calculated w.r.t the point (5,5,5).

henry

2018-12-27 08:40

manager   ~0010237

This all depends on the coordinate system used. Please provide equivalent cases which demonstrate a difference in behavior.

henry

2018-12-31 16:25

manager   ~0010248

Please open another report when you can supply a case which demonstrates the issue.

Issue History

Date Modified Username Field Change
2018-12-27 06:39 dominic.chandar New Issue
2018-12-27 08:16 henry Priority urgent => normal
2018-12-27 08:16 henry Severity major => minor
2018-12-27 08:18 henry Note Added: 0010235
2018-12-27 08:29 dominic.chandar Note Added: 0010236
2018-12-27 08:40 henry Note Added: 0010237
2018-12-31 16:25 henry Assigned To => henry
2018-12-31 16:25 henry Status new => closed
2018-12-31 16:25 henry Resolution open => unable to reproduce
2018-12-31 16:25 henry Note Added: 0010248