View Issue Details

IDProjectCategoryView StatusLast Update
0003121OpenFOAMFeaturepublic2018-12-04 18:55
ReportersaideepAssigned Tohenry 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionno change required 
Product Version 
Fixed in Version 
Summary0003121: Complex interface curvature equation in "interfaceProperties.C"
DescriptionI reported this observation few months ago but unable to find it here now. So, I will keep it short and to the point.

Solver: "interFoam"

I have a paddle (see attached figure) and I am using 0 contact angle. So, wetting phase must slide over wall surface. Using common curvature equation below does not do the job.
// Simple expression for curvature
K_ = -fvc::div(nHatf_);

So, when I reported here earlier, Henry suggested to change the mesh (I tried several other meshes - cfMesh, Fluent but sHM was the best) or use a different equation to compute the curvature. After trying so long, the solution was pretty simple, I used the "complex expression for computing the interface curvature" see below (that has been commented out in all versions of OF):
//Complex curvature equation
    volVectorField nHat(gradAlpha/(mag(gradAlpha) + deltaN_));
    K_ = -fvc::div(nHatf_) + (nHat & fvc::grad(nHatfv) & nHat);

I could not find any literature regarding the correction term. Could you explain how does this correction term work (any link/ paper)? From my understanding the correction term could probably be proved mathematically it is 0. However, in reality it is not due to the lower order schemes being used on unstructured meshes.
TagsNo tags attached.

Activities

saideep

2018-12-04 18:31

reporter  

Paddle.png (28,568 bytes)
Paddle.png (28,568 bytes)

henry

2018-12-04 18:55

manager   ~0010203

User support request.

Issue History

Date Modified Username Field Change
2018-12-04 18:31 saideep New Issue
2018-12-04 18:31 saideep File Added: Paddle.png
2018-12-04 18:55 henry Assigned To => henry
2018-12-04 18:55 henry Status new => closed
2018-12-04 18:55 henry Resolution open => no change required
2018-12-04 18:55 henry Note Added: 0010203