View Issue Details

IDProjectCategoryView StatusLast Update
0003116OpenFOAMBugpublic2018-12-05 00:28
ReporterGang LiuAssigned Towyldckat 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionno change required 
PlatformIntel(2016.4)/LinuxOSLinux CentOSOS Version7.5.1804 (Core)
Product Version6 
Fixed in Version 
Summary0003116: I was trying to compile OpenQBMM, but met "corrupted double-linked list" error.
DescriptionI was trying to compile and install OpenQBMM package, which is an extension of OpenFoam. Almost immediately in compiling, the following

*** Error in `.../openfoam/6/OpenFOAM-6/wmake/platforms/linux64Icc/wmkdep': corrupted double-linked list: 0x0000000001d212d0 ***
Steps To Reproducemkdir OpenQBMM-dev
cd OpenQBMM-dev

git clone https://github.com/OpenQBMM/OpenQBMM.git

cd OpenQBMM

git checkout -b development origin/development

module load openfoam/6

find $cwd -type f -exec sed -i 's/HUGE/GREAT/g' {} \;

./Allwmake
 

Soon the error comes:
...
wmakeLnInclude: linking include files to ./lnInclude
Making dependency list for source file eigenSolver.C
make: *** Deleting file 'Make/linux64IccDPInt32Opt/eigenSolver.C.dep'
make: *** No rule to make target 'Make/linux64IccDPInt32Opt/eigenSolver.C.dep', needed by 'Make/linux64IccDPInt32Opt/eigenSolver.o'. Stop.
+ wmake libso Vandermonde
wmake libso Vandermonde
wmakeLnInclude: linking include files to ./lnInclude
Making dependency list for source file Vandermonde.C
make: *** Deleting file 'Make/linux64IccDPInt32Opt/Vandermonde.C.dep'
make: *** No rule to make target 'Make/linux64IccDPInt32Opt/Vandermonde.C.dep', needed by 'Make/linux64IccDPInt32Opt/Vandermonde.o'. Stop.
+ wmake libso quadratureMethods/momentSets
wmake libso quadratureMethods/momentSets
wmakeLnIncludeAll: running wmakeLnInclude on dependent libraries:
    wmakeLnInclude: linking include files to ../momentSets//lnInclude
Making dependency list for source file multivariateMomentSet.C
*** Error in `.../openfoam/6/OpenFOAM-6/wmake/platforms/linux64Icc/wmkdep': corrupted double-linked list: 0x0000000001d212d0 ***
TagsNo tags attached.

Activities

wyldckat

2018-12-05 00:27

updater   ~0010205

Even though the OpenQBMM source code and Copyright was transferred to the OpenFOAM Foundation, it looks like the repository + branch from which you checked out the source code still has its own issue tracker: https://github.com/OpenQBMM/OpenQBMM/issues

Please report this issue there and please also indicate which exact build of OpenFOAM you are using... you can check by running this command:

    blockMesh -help

and the last few lines should tell you the exact build version being used.

Issue History

Date Modified Username Field Change
2018-12-03 17:56 Gang Liu New Issue
2018-12-05 00:27 wyldckat Note Added: 0010205
2018-12-05 00:28 wyldckat Assigned To => wyldckat
2018-12-05 00:28 wyldckat Status new => closed
2018-12-05 00:28 wyldckat Resolution open => no change required