View Issue Details

IDProjectCategoryView StatusLast Update
0003081ThirdParty[All Projects] Bugpublic2018-10-05 21:30
Reporterhandrake0724Assigned Tohenry 
PrioritylowSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnixOSOtherOS Version(please specify)
Product Versiondev 
Fixed in Versiondev 
Summary0003081: typo in turbulentTransportModel.H
Descriptionwhen I look into turbulentTransportModel.H, there is a selector reads

        template<class BasicCompressibleTurbulenceModel>
        autoPtr<BasicCompressibleTurbulenceModel> New
        (
            const volVectorField& U,
            const surfaceScalarField& phi,
            const typename BasicCompressibleTurbulenceModel::transportModel&
                transport,
            const word& propertiesName = turbulenceModel::propertiesName
        );

I guess the template parameter BasicCompressibleTurbulenceModel is misspelled and should be corrected BasicIncompressibleTurbulenceModel since it is in the namespace incompressible instead of compressible.
TagsNo tags attached.

Activities

henry

2018-10-05 21:30

manager   ~0010083

Resolved by commit ff2c2dfea34b0233b096f0d0112242b30875a453

Issue History

Date Modified Username Field Change
2018-10-05 16:58 handrake0724 New Issue
2018-10-05 21:28 henry Priority normal => low
2018-10-05 21:28 henry Severity minor => trivial
2018-10-05 21:30 henry Assigned To => henry
2018-10-05 21:30 henry Status new => resolved
2018-10-05 21:30 henry Resolution open => fixed
2018-10-05 21:30 henry Fixed in Version => dev
2018-10-05 21:30 henry Note Added: 0010083