View Issue Details

IDProjectCategoryView StatusLast Update
0003067OpenFOAM[All Projects] Bugpublic2018-09-06 00:05
ReporterguinAssigned Tohenry 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version16.04
Product Version6 
Fixed in Version6 
Summary0003067: Wrong linking being used by "-doc" & "-srcDoc" options
Description"-doc" and "-srcDoc" flags for the solvers seem to work ALMOST as intended for the solvers. It simply needs adding a version check.
However, when used for other utilities e.g. blockMesh, the links appear to be broken. After a short series of tests I have some doubts:
    - There is a current inconsistency between the strategy followed with solvers and utilities regarding their documentation, though they (generally) follow the same structure i.e. contain a short description in the header of the main C-file. Does the way used by "-doc"/"-srcDoc" to guess the links to follow fail? or is it a problem of how utilities-related info is stored by Doxygen?
    - In general, should "-srcDoc" point to https://cpp.openfoam.org or directly to https://github.com/OpenFOAM/?
Steps To ReproduceFrom within OpenFOAM-6 (repository-version):

pimpleFoam -doc
    - It opens https://cpp.openfoam.org/dev/pimpleFoam_8C.html
    - One would expect it to open https://cpp.openfoam.org/v6/pimpleFoam_8C.html (its own version variant)

pimpleFoam -srcDoc
    - It opens https://cpp.openfoam.org/dev/pimpleFoam_8C_source.html
    - One would expect it to open https://cpp.openfoam.org/v6/pimpleFoam_8C_source.html (its own version variant)

blockMesh -doc
    - It tries to open https://cpp.openfoam.org/dev/blockMesh_8C.html (which, somehow does not exist)
    - One would expect it to open https://cpp.openfoam.org/v6/blockMesh_8C.html (but this link does not exist either)
    - Manual search for "blockMesh" at https://cpp.openfoam.org/v6 finally takes one to either https://cpp.openfoam.org/v6/classFoam_1_1blockMesh.html or to https://cpp.openfoam.org/v6/applications_2utilities_2mesh_2generation_2blockMesh_2blockMesh_8C.html (more manually) (both seem to be the actual links including the header information from the C-file)

blockMesh -srcDoc (same story as above)
    - It opens https://cpp.openfoam.org/dev/blockMesh_8C_source.html (which, somehow does not exist)
    - One would expect it to open https://cpp.openfoam.org/v6/blockMesh_8C_source.html (but this link does not exist either)
    - Manual search at https://cpp.openfoam.org/v6 finally takes one to https://cpp.openfoam.org/v6/applications_2utilities_2mesh_2generation_2blockMesh_2blockMesh_8C_source.html (I couldn't find a shorter link so far)
Additional InformationFrom within https://cpp.openfoam.org/dev/classFoam_1_1blockMesh.html, scrolling down to the scope "Detailed Description" and clicking on any of the "Source files", one gets redirected to the github repository. For instantce, clicking on "blockMesh.C" opens https://github.com/OpenFOAM/OpenFOAM-6/blob/master/src/mesh/blockMesh/blockMesh/blockMesh.C
TagsNo tags attached.

Activities

henry

2018-09-05 18:10

manager   ~0010038

The general problem is resolved by commit 9668a8ca7bbc2426dbb3cc8555c3249bf05fe0c5

However the problem with blockMesh appears to be due to a limitation of Doxygen or at least the way in which it is configured such that the name clash between the blockMesh class and the blockMesh application is stopping the documentation for the application being generated. Can you look into this?

henry

2018-09-06 00:05

manager   ~0010039

Resolved in OpenFOAM-6 by commit a9be0f471a07b49f470b1b564abcdee223b52cb7
Resolved in OpenFOAM-dev by commit 0dfcae6a26d992b18ec91a5347558bb20f62f955

The change will propagate to the online repositories next time the documentation is regenerated.

Issue History

Date Modified Username Field Change
2018-09-05 17:24 guin New Issue
2018-09-05 18:10 henry Note Added: 0010038
2018-09-06 00:05 henry Assigned To => henry
2018-09-06 00:05 henry Status new => resolved
2018-09-06 00:05 henry Resolution open => fixed
2018-09-06 00:05 henry Fixed in Version => 6
2018-09-06 00:05 henry Note Added: 0010039