View Issue Details

IDProjectCategoryView StatusLast Update
0003055OpenFOAMFeaturepublic2018-11-30 20:45
ReporterAllanBjerg Assigned Tochris  
Status resolvedResolutionfixed 
PlatformGNU/LinuxOSUbuntuOS Version18.04.1
Summary0003055: "postProcess -func yPlus" cannot calculate y+ for more than 1 folder at a time
DescriptionI am making a simulation in openFOAM 6 and trying to calculate y+ using the postProcess tool. I am using the "pitzDaily" from "opt/tutorial/openfoam6/tutorials/incompressible/pisoFoam/LES". When I run the command: "pisoFoam -postProcess -func yPlus" it can only calculate the y+ values for the first folder after which the following error occur:

    request for volScalarField yPlus from objectRegistry region0 failed
    available objects of type volScalarField are


    From function const Type& Foam::objectRegistry::lookupObject(const Foam::word&) const [with Type = Foam::GeometricField<double, Foam::fvPatchField, Foam::volMesh>]
    in file /home/ubuntu/OpenFOAM/OpenFOAM-6/src/OpenFOAM/lnInclude/objectRegistryTemplates.C at line 193.

FOAM aborting

#0 Foam::error::printStack(Foam::Ostream&) at ??:?
#1 Foam::error::abort() at ??:?
#2 Foam::GeometricField<double, Foam::fvPatchField, Foam::volMesh> const& Foam::objectRegistry::lookupObject<Foam::GeometricField<double, Foam::fvPatchField, Foam::volMesh> >(Foam::word const&) const at ??:?
#3 Foam::functionObjects::yPlus::execute() at ??:?
#4 Foam::functionObjects::timeControl::execute() at ??:?
#5 Foam::functionObjectList::execute() at ??:?
#6 ? in "/opt/openfoam6/platforms/linux64GccDPInt32Opt/bin/pisoFoam"
#7 __libc_start_main in "/lib/x86_64-linux-gnu/"
#8 ? in "/opt/openfoam6/platforms/linux64GccDPInt32Opt/bin/pisoFoam"
Aborted (core dumped)

The very same procedure worked in openFOAM 5.x.
Steps To Reproduce1. Make a copy of the "pitzDaily" to the desktop. It is found in: "opt/tutorial/openfoam6/tutorials/incompressible/pisoFoam/LES"
2. Open a terminal in the "pitzDaily" folder
3. run: blockMesh
4. run: pisoFoam
after the simulation is done
5. run: pisoFoam -postProcess -func yPlus
TagsNo tags attached.


related to 0003019 resolvedwill OF 6 wallHeatFlux utility not working on chtMultiRegionFoam tutorials 



2018-08-27 17:51

updater   ~0009998

This should have already been fixed in the latest Deb package installation, given that it was fixed before its release on the 5th of August. Therefore if you installed the OpenFOAM Foundation Deb packages, then please follow the update instructions given here:

The commit in which this was fixed was this:

If you installed from source code, then please indicate which installation instructions you've followed.


2018-08-28 10:25

reporter   ~0010001

I have removed my current OpenFOAM 6 and re-installed it from the source repository. Now it works fine!

Thank you for your help!


2018-08-28 10:58

updater   ~0010002

@AllanBjerg: You're welcome and many thanks for you feedback!

Closing this as already resolved in Issue #0003019 by Will.


2018-09-01 16:59

updater   ~0010031

I should have checked this sooner without closing this issue, but the latest Deb package 20180805 does not yet have the bug fix for this issue.

I've re-opened this issue and leave it unassigned till after the "OpenFOAM Open Day 2018".


2018-11-30 20:45

updater   ~0010198

Given that this report was originally reported for the Deb packages, I had reopened it after closing it as resolved... but finally this can be closed as resolved, with today's updated Deb packages: - including package for Ubuntu 18.10 (cosmic)!

Issue History

Date Modified Username Field Change
2018-08-27 15:37 AllanBjerg New Issue
2018-08-27 17:51 wyldckat Note Added: 0009998
2018-08-27 17:51 wyldckat Relationship added related to 0003019
2018-08-28 10:25 AllanBjerg Note Added: 0010001
2018-08-28 10:58 wyldckat Assigned To => will
2018-08-28 10:58 wyldckat Status new => resolved
2018-08-28 10:58 wyldckat Resolution open => fixed
2018-08-28 10:58 wyldckat Fixed in Version => 6
2018-08-28 10:58 wyldckat Note Added: 0010002
2018-09-01 16:59 wyldckat Assigned To will =>
2018-09-01 16:59 wyldckat Status resolved => feedback
2018-09-01 16:59 wyldckat Resolution fixed => reopened
2018-09-01 16:59 wyldckat Note Added: 0010031
2018-11-30 20:45 wyldckat Assigned To => chris
2018-11-30 20:45 wyldckat Status feedback => resolved
2018-11-30 20:45 wyldckat Resolution reopened => fixed
2018-11-30 20:45 wyldckat Note Added: 0010198